summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-05 09:29:57 +0100
committerSam James <sam@gentoo.org>2023-06-05 09:29:57 +0100
commit7183e10e4801316e3f83f89d95890f26eeea99b1 (patch)
treea211bff942cc3181f2a95dfc7907f06795ba3843 /dev-util/pkgdev
parentsys-block/nbd: Stabilize 3.25 x86, #907863 (diff)
downloadgentoo-7183e10e4801316e3f83f89d95890f26eeea99b1.tar.gz
gentoo-7183e10e4801316e3f83f89d95890f26eeea99b1.tar.bz2
gentoo-7183e10e4801316e3f83f89d95890f26eeea99b1.zip
dev-util/pkgdev: set EGIT_BRANCH
HEAD is supposed to be main already but smart-live-rebuild is confused for some reason and tries to always rebuild, so try this. ("!!! Error updating dev-util/pkgdev:0: [Exception] update command failed to return a rev", thanks to xgqt for poking about it) Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/pkgdev')
-rw-r--r--dev-util/pkgdev/pkgdev-0.2.5.ebuild1
-rw-r--r--dev-util/pkgdev/pkgdev-0.2.7.ebuild1
-rw-r--r--dev-util/pkgdev/pkgdev-9999.ebuild1
3 files changed, 3 insertions, 0 deletions
diff --git a/dev-util/pkgdev/pkgdev-0.2.5.ebuild b/dev-util/pkgdev/pkgdev-0.2.5.ebuild
index 6b23773e717e..71f38afb7435 100644
--- a/dev-util/pkgdev/pkgdev-0.2.5.ebuild
+++ b/dev-util/pkgdev/pkgdev-0.2.5.ebuild
@@ -8,6 +8,7 @@ PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1 optfeature
if [[ ${PV} == *9999 ]] ; then
+ EGIT_BRANCH="main"
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/pkgcore/pkgdev.git
https://github.com/pkgcore/pkgdev.git"
inherit git-r3
diff --git a/dev-util/pkgdev/pkgdev-0.2.7.ebuild b/dev-util/pkgdev/pkgdev-0.2.7.ebuild
index 14129a01f8f2..f4073bb87c38 100644
--- a/dev-util/pkgdev/pkgdev-0.2.7.ebuild
+++ b/dev-util/pkgdev/pkgdev-0.2.7.ebuild
@@ -8,6 +8,7 @@ PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 optfeature
if [[ ${PV} == *9999 ]] ; then
+ EGIT_BRANCH="main"
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/pkgcore/pkgdev.git
https://github.com/pkgcore/pkgdev.git"
inherit git-r3
diff --git a/dev-util/pkgdev/pkgdev-9999.ebuild b/dev-util/pkgdev/pkgdev-9999.ebuild
index 443eaca01b69..fddbae4e45a4 100644
--- a/dev-util/pkgdev/pkgdev-9999.ebuild
+++ b/dev-util/pkgdev/pkgdev-9999.ebuild
@@ -8,6 +8,7 @@ PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 optfeature
if [[ ${PV} == *9999 ]] ; then
+ EGIT_BRANCH="main"
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/pkgcore/pkgdev.git
https://github.com/pkgcore/pkgdev.git"
inherit git-r3