summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <rahil3108@gmail.com>2023-10-01 16:16:59 +0530
committerZac Medico <zmedico@gentoo.org>2023-10-01 20:36:14 -0700
commit4b1686dfef9d664fd96b0c8241879321a62e3e1c (patch)
treee1d74c0c46435ea564ce8b37d27163ae27ea491f /dev-util/promu
parentscripts/bootstrap.sh: Don't bail if 'emerge --prune' returns 1 (diff)
downloadgentoo-4b1686dfef9d664fd96b0c8241879321a62e3e1c.tar.gz
gentoo-4b1686dfef9d664fd96b0c8241879321a62e3e1c.tar.bz2
gentoo-4b1686dfef9d664fd96b0c8241879321a62e3e1c.zip
dev-util/promu: add 0.15.0 & live
rewrote to be in more align with upstream's instructions Closes: https://github.com/gentoo/gentoo/pull/33145 Signed-off-by: Rahil Bhimjiani <rahil3108@gmail.com> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-util/promu')
-rw-r--r--dev-util/promu/Manifest2
-rw-r--r--dev-util/promu/metadata.xml10
-rw-r--r--dev-util/promu/promu-0.15.0.ebuild47
-rw-r--r--dev-util/promu/promu-9999.ebuild47
4 files changed, 106 insertions, 0 deletions
diff --git a/dev-util/promu/Manifest b/dev-util/promu/Manifest
index d0f72ebc4f7f..3c1653f92685 100644
--- a/dev-util/promu/Manifest
+++ b/dev-util/promu/Manifest
@@ -2,3 +2,5 @@ DIST promu-0.13.0-deps.tar.xz 106902576 BLAKE2B c09fadd7957896a452f3d34bf066eddc
DIST promu-0.13.0.tar.gz 46099 BLAKE2B 674580c4b853881db6307f065678afdb561fcab51be6ad3ac604849b6a7f3c63b1eb5f5be4f4ee533f25e087b3ed19bb7584ee5c72b30b8c0e33d19f690cc115 SHA512 04feddf514417e636498d111b0cc9678af4b1c2be16eb61f257e013b10ec427b5055d54150a76dce0867d659ca7e8833702e29bdf32cb00d5d02dad906c3de21
DIST promu-0.14.0-deps.tar.xz 9838972 BLAKE2B 110e71d59c05974ca2fd953c240b3f798e22bd9631463a6c211714dc9a0782fba38c6114180fe999e11de8776a8eb0a8e807e3ff6bc56cab7a3b3711c1846ff6 SHA512 675d4d16c2278064d7fe6b22c3e92c6e4bba865649342c1af7d7f3c99e35fc4679d132ca12ff5ea45bac64d8a40319dd55023bda1bbc601884c28da10103c1b7
DIST promu-0.14.0.tar.gz 47254 BLAKE2B d944677b1ceb3cb6e6ff8fb1a04cb5df54b8731c7d721a6c8016ea96e8a7696f238fe614ff2011b0c3c2b6240799125bf6ec4ccacecd8fea16e35e29fc8e347b SHA512 709214f72f6ad1e4cbd04cb92b2f10efa2f198265f3a3e2274e8a454a2e24ce42db024d15e26f8bb5f9e3c8672d212dac6b0a52cead8dde9e425f0bf72577260
+DIST promu-0.15.0-deps.tar.xz 11022948 BLAKE2B e8f1a65dca92147c1f617dbfb7279c1eb45efcdc93a019c7a4fb9e9ff2895e71283e1368751e37732972554d7dce20ed08553f9e3111efa2b48eb0c86e191a06 SHA512 f4d1456969ea5454990ccebf81d49e857e3a6311b81dfcdb2538e82e8b7842d1020fd489567a10534759d44c69f6adb1e70f9de4b36c24286908c5758b8fd05d
+DIST promu-0.15.0.tar.gz 33465 BLAKE2B 83fae1e8cf663fe9aaedbdf66d86f3d4d7db0b14572cec9f0e9b25a205712cf19b137f6cafa3adcc0cbdd9177078a1bc696b9333ae830cf38de83e4837829abf SHA512 7e1de86c67b7a6d469e49b63431c9be1f93295f79225bfe409deef426c11c2f5273e185ef3b53ff5fd5fd41ddf7d9ddc79c2629e34a7ae2ec55adebdf8ff3b44
diff --git a/dev-util/promu/metadata.xml b/dev-util/promu/metadata.xml
index 9a9b03c07115..0d1185897523 100644
--- a/dev-util/promu/metadata.xml
+++ b/dev-util/promu/metadata.xml
@@ -5,7 +5,17 @@
<email>zmedico@gentoo.org</email>
<name>Zac Medico</name>
</maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>rahil3108@gmail.com</email>
+ <name>Rahil Bhimjiani</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<upstream>
<remote-id type="github">prometheus/promu</remote-id>
+ <bugs-to>https://github.com/prometheus/promu/issues</bugs-to>
+ <doc>https://github.com/prometheus/promu/blob/master/README.md</doc>
</upstream>
</pkgmetadata>
diff --git a/dev-util/promu/promu-0.15.0.ebuild b/dev-util/promu/promu-0.15.0.ebuild
new file mode 100644
index 000000000000..36b0779a8ac2
--- /dev/null
+++ b/dev-util/promu/promu-0.15.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="Prometheus Utility Tool"
+HOMEPAGE="https://github.com/prometheus/promu"
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/prometheus/promu.git"
+else
+ SRC_URI="https://github.com/prometheus/promu/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI+=" https://github.com/rahilarious/gentoo-distfiles/releases/download/${P}/deps.tar.xz -> ${P}-deps.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+LICENSE="Apache-2.0"
+LICENSE+=" BSD BSD-2 MIT"
+SLOT="0"
+
+RESTRICT+=" test"
+DOCS=(
+ "doc/examples"
+ "README.md"
+)
+
+src_unpack() {
+ if [[ ${PV} == *9999* ]]; then
+ git-r3_src_unpack
+ go-module_live_vendor
+ else
+ go-module_src_unpack
+ fi
+}
+
+src_compile() {
+ emake build
+}
+
+src_install() {
+ if [[ ${PV} == *9999 ]]; then
+ dobin "${PN}"
+ else
+ newbin "${P}" "${PN}"
+ fi
+ einstalldocs
+}
diff --git a/dev-util/promu/promu-9999.ebuild b/dev-util/promu/promu-9999.ebuild
new file mode 100644
index 000000000000..36b0779a8ac2
--- /dev/null
+++ b/dev-util/promu/promu-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="Prometheus Utility Tool"
+HOMEPAGE="https://github.com/prometheus/promu"
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/prometheus/promu.git"
+else
+ SRC_URI="https://github.com/prometheus/promu/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI+=" https://github.com/rahilarious/gentoo-distfiles/releases/download/${P}/deps.tar.xz -> ${P}-deps.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+LICENSE="Apache-2.0"
+LICENSE+=" BSD BSD-2 MIT"
+SLOT="0"
+
+RESTRICT+=" test"
+DOCS=(
+ "doc/examples"
+ "README.md"
+)
+
+src_unpack() {
+ if [[ ${PV} == *9999* ]]; then
+ git-r3_src_unpack
+ go-module_live_vendor
+ else
+ go-module_src_unpack
+ fi
+}
+
+src_compile() {
+ emake build
+}
+
+src_install() {
+ if [[ ${PV} == *9999 ]]; then
+ dobin "${PN}"
+ else
+ newbin "${P}" "${PN}"
+ fi
+ einstalldocs
+}