summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-12-04 23:17:16 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2018-12-04 23:43:07 +0000
commitd8801c696cb08f7a0d7c65511680a54cd1f684d4 (patch)
tree15c9148c3f0adce91244386280adc97b1015a455 /dev-util/radare2/radare2-3.1.3.ebuild
parentsys-apps/openrc: 0.40.1 bug fix release (diff)
downloadgentoo-d8801c696cb08f7a0d7c65511680a54cd1f684d4.tar.gz
gentoo-d8801c696cb08f7a0d7c65511680a54cd1f684d4.tar.bz2
gentoo-d8801c696cb08f7a0d7c65511680a54cd1f684d4.zip
dev-util/radare2: bump up to 2.1.3
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util/radare2/radare2-3.1.3.ebuild')
-rw-r--r--dev-util/radare2/radare2-3.1.3.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-util/radare2/radare2-3.1.3.ebuild b/dev-util/radare2/radare2-3.1.3.ebuild
new file mode 100644
index 000000000000..ccba9bfa0ed9
--- /dev/null
+++ b/dev-util/radare2/radare2-3.1.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 eutils
+
+DESCRIPTION="unix-like reverse engineering framework and commandline tools"
+HOMEPAGE="http://www.radare.org"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/radare/radare2"
+else
+ SRC_URI="https://github.com/radare/radare2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="ssl libressl"
+
+RDEPEND="
+ dev-libs/capstone:0=
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --without-libuv \
+ --with-syscapstone \
+ $(use_with ssl openssl)
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/zsh/site-functions
+ doins doc/zsh/_*
+
+ newbashcomp doc/bash_autocompletion.sh "${PN}"
+ bashcomp_alias "${PN}" rafind2 r2 rabin2 rasm2 radiff2
+
+ # a workaround for unstable $(INSTALL) call, bug #574866
+ local d
+ for d in doc/*; do
+ if [[ -d $d ]]; then
+ rm -rfv "$d" || die "failed to delete '$d'"
+ fi
+ done
+}