summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-10 18:31:31 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-10 18:47:08 +0200
commit9b1a1bd2c395c389e8f1003f691249232fecc1ba (patch)
tree1a12a6b1d85723fd64d2bb2727de4d3ed988fcbc /dev-util/stripe-mock
parentdev-python/pyzotero: Add python@ as co-maint. (diff)
downloadgentoo-9b1a1bd2c395c389e8f1003f691249232fecc1ba.tar.gz
gentoo-9b1a1bd2c395c389e8f1003f691249232fecc1ba.tar.bz2
gentoo-9b1a1bd2c395c389e8f1003f691249232fecc1ba.zip
dev-util/stripe-mock: Bump to 0.107.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/stripe-mock')
-rw-r--r--dev-util/stripe-mock/Manifest1
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.107.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-util/stripe-mock/Manifest b/dev-util/stripe-mock/Manifest
index e5039c3871d5..6e1705b71e6c 100644
--- a/dev-util/stripe-mock/Manifest
+++ b/dev-util/stripe-mock/Manifest
@@ -2,3 +2,4 @@ DIST stripe-mock-0.103.0.tar.gz 567107 BLAKE2B 76dbc6bbb1d62ea68c30291fea894e563
DIST stripe-mock-0.104.0.tar.gz 574936 BLAKE2B 681dcc2b02f5d4ca946024d1c049e499ce1c05c5a00653ca5a1af25325ce66b651e307df12ac0137fb38478332a8a04fb09ced39afa697a81a4afcc69a1cf314 SHA512 6d9c5fe5e5e83e8721ae441ae15e16594c690360a62934e825627add8acf6d58b0c4f52bd2c6d787c934fe0e974790b35b7c63d02f097647744549626b1708c5
DIST stripe-mock-0.105.0.tar.gz 583483 BLAKE2B 8015699be4cd7a0c6e81c8f89cebe23fadb02904a175fef15c5e1fe156b01b001a03ba4b42ddffd453203142b1108d5981782d23e1369bab61181e0ef3964734 SHA512 539c3315c3e4896584a656fa3157ac69331bdaf2c77b6a7433b8709971e3b248fe89f1df3eab3f3178580847109460b86f975f0a378aef48ca3c29466b076f52
DIST stripe-mock-0.106.0.tar.gz 592320 BLAKE2B 2154898ecb13516d11fe5188012829af5618a0520b19d6c3899c976ef719e5ddfe0a1bfe0c6787b9e51c695734d90e2297b8df6abc7d055a8d4df8e747d16b08 SHA512 30d5db6ace639435f0c97ce2ff38c02acdb464a09d5cf59a90ea3892b5f277e05ffb67d068b74739c2cdca3e73b2db74054079335bb28536c57457b46251bd6d
+DIST stripe-mock-0.107.0.tar.gz 592857 BLAKE2B 6fb58e6c38a04e443adf68bd30dbe16531abede29c104c617bd16f7fd9ce19b38bcd43df2b3fc21e9f8f5cf58a9e6413158f09a0e4746721e29180bfa8e5a26c SHA512 c455f18c242d15e20022fa17a99d4fb33ba93932d6983eb589b4e084b1bd2739a1db837ae70c4043cc4333a5a13ff4f4b16785a9ab014e556901fa975380e90b
diff --git a/dev-util/stripe-mock/stripe-mock-0.107.0.ebuild b/dev-util/stripe-mock/stripe-mock-0.107.0.ebuild
new file mode 100644
index 000000000000..05a7220e34b0
--- /dev/null
+++ b/dev-util/stripe-mock/stripe-mock-0.107.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGO_SRC="github.com/stripe/stripe-mock"
+EGO_PN=${EGO_SRC}/...
+inherit golang-build golang-vcs-snapshot
+
+DESCRIPTION="Mock HTTP server that responds like the real Stripe API"
+HOMEPAGE="https://github.com/stripe/stripe-mock"
+SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT ISC BSD-2"
+SLOT="0"
+
+src_install() {
+ golang-build_src_install
+ dobin bin/stripe-mock
+ rm -rf "${D}$(get_golibdir_gopath)" || die
+}