summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-26 18:24:47 +0100
committerSam James <sam@gentoo.org>2023-06-26 18:44:54 +0100
commit46a745ed826efe2380bcc26c03166224c360879b (patch)
tree0418e2a3aeab9fd8ca5d3c894ee5c50f78e63559 /dev-util
parentapp-emacs/clojure-mode: bump to 5.16.1 (diff)
downloadgentoo-46a745ed826efe2380bcc26c03166224c360879b.tar.gz
gentoo-46a745ed826efe2380bcc26c03166224c360879b.tar.bz2
gentoo-46a745ed826efe2380bcc26c03166224c360879b.zip
dev-util/lttng-ust: add 2.13.6
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/lttng-ust/Manifest1
-rw-r--r--dev-util/lttng-ust/lttng-ust-2.13.6.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-util/lttng-ust/Manifest b/dev-util/lttng-ust/Manifest
index ff5bde28ba82..d2a97a881c8b 100644
--- a/dev-util/lttng-ust/Manifest
+++ b/dev-util/lttng-ust/Manifest
@@ -4,3 +4,4 @@ DIST lttng-ust-2.12.2.tar.bz2 861351 BLAKE2B 0c580285721b3d7932630c8d9f4a3606ee2
DIST lttng-ust-2.12.4.tar.bz2 772723 BLAKE2B cf9782d7b0ab39b1eeebd3f21a31d7a249c9f4f4b1c28746d27ad4dfc0196a4d71dd3d837bfa211ab98c1b555b79b4fa6b39b341312d8b5cc6c47708fa0e8963 SHA512 c2935c9aa63446ceeff1d6fe76367883a3b188c113fcc25c83848b4ee89497a614dfc0b32f920a0c5054c6208bc37899482d40938a1fc37ad890b7c5172fc20b
DIST lttng-ust-2.13.2.tar.bz2 1327075 BLAKE2B 39296ba62fcf5518b16d67f196ab4788c78b41eeadb5f8037c2445ac13a95754e7723399f58f6b21734d8931ae0d68d1dea28b74759fd531fac6a9308817bc09 SHA512 2392b0aeabbaea6daf62a9c752a04ea3043e1cc2d93064b073fd4438beac0d30832aea9b2f158cc8b90b3d98f427bca2999cce4e873fa3f82e04693e13ed9fb3
DIST lttng-ust-2.13.5.tar.bz2 1336658 BLAKE2B 0e61688c34c7d360829cdc6b265ac5ffb4186f4eddf7f5de10cd2e0b4ee7b570b59c43658c7d9b4853de40ca22add8ad6068047271d7587a43151ba9feba8532 SHA512 3bf969e9deb6ce05a1ae30ad48676ae8ff63a73198583e98ce083d52b78e9fc2d171a6e3890c201abfa364600d4471d1ee8b1ee23de3faeec1f0ca84e0f0acd4
+DIST lttng-ust-2.13.6.tar.bz2 1351915 BLAKE2B c350a7302e38035ef7c6727ea942907ec606c88862ae875bed0a7c833f233b4159405bcb7a41549dccf3d79491151066d593c52d9f06b95b61c345ccbace62f5 SHA512 15458f8dd0ad6fa96a9cf7569ffabadfddcaa70b822b69b39d4d7dfba3701c9489706b06f12f9d7e376147299fb3cfc6fe1213d46d510bdb7b3dc834271da55f
diff --git a/dev-util/lttng-ust/lttng-ust-2.13.6.ebuild b/dev-util/lttng-ust/lttng-ust-2.13.6.ebuild
new file mode 100644
index 000000000000..1a0f2ce53e3b
--- /dev/null
+++ b/dev-util/lttng-ust/lttng-ust-2.13.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Please bump the following packages together:
+# dev-util/lttng-modules
+# dev-util/lttng-tools
+# dev-util/lttng-ust
+
+MY_P="${P/_rc/-rc}"
+MY_SLOT="$(ver_cut 1-2)"
+
+DESCRIPTION="Linux Trace Toolkit - UST library"
+HOMEPAGE="https://lttng.org"
+SRC_URI="https://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0/${MY_SLOT}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="examples numa test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/userspace-rcu-0.12:=
+ numa? ( sys-process/numactl )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? ( dev-lang/perl )
+"
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ pthread_get_name_np # different from pthread_getname_*, not on linux
+ pthread_set_name_np # different from pthread_setname_*, not on linux
+)
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable examples)
+ $(use_enable numa)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}