summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-08-15 19:45:11 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-08-15 20:04:36 -0400
commit4b95aca7d5f0a0b19b3f18cc92bbb813a58ab795 (patch)
tree1a23f58e8eadc2ef5d2c915653cb1a62cdb73073 /dev-util
parentx11-terms/kitty: remove redundant workaround (diff)
downloadgentoo-4b95aca7d5f0a0b19b3f18cc92bbb813a58ab795.tar.gz
gentoo-4b95aca7d5f0a0b19b3f18cc92bbb813a58ab795.tar.bz2
gentoo-4b95aca7d5f0a0b19b3f18cc92bbb813a58ab795.zip
dev-util/maturin: skip test broken by cargo.eclass changes
Bug: https://bugs.gentoo.org/936968 Closes: https://bugs.gentoo.org/937992 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/maturin/maturin-1.6.0.ebuild3
-rw-r--r--dev-util/maturin/maturin-1.7.0.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/dev-util/maturin/maturin-1.6.0.ebuild b/dev-util/maturin/maturin-1.6.0.ebuild
index da76be521596..0db2445f7122 100644
--- a/dev-util/maturin/maturin-1.6.0.ebuild
+++ b/dev-util/maturin/maturin-1.6.0.ebuild
@@ -532,7 +532,6 @@ python_compile_all() {
}
python_test() {
- local -x COLUMNS=100 # match clap_builder crate default
local -x MATURIN_TEST_PYTHON=${EPYTHON}
local -x PIP_CONFIG_FILE=${T}/pip.conf
local -x VIRTUALENV_SYSTEM_SITE_PACKAGES=1
@@ -541,6 +540,8 @@ python_test() {
local -x PYO3_USE_ABI3_FORWARD_COMPATIBILITY=1
local skip=(
+ # picky cli output test that easily benignly fail (bug #937992)
+ --skip cli_tests
# avoid need for wasm over a single hello world test
--skip integration_wasm_hello_world
# fragile depending on rust version, also wants libpypy*-c.so for pypy
diff --git a/dev-util/maturin/maturin-1.7.0.ebuild b/dev-util/maturin/maturin-1.7.0.ebuild
index 6099d2180ca1..78feb9dcf851 100644
--- a/dev-util/maturin/maturin-1.7.0.ebuild
+++ b/dev-util/maturin/maturin-1.7.0.ebuild
@@ -487,7 +487,6 @@ python_compile_all() {
}
python_test() {
- local -x COLUMNS=100 # match clap_builder crate default
local -x MATURIN_TEST_PYTHON=${EPYTHON}
local -x PIP_CONFIG_FILE=${T}/pip.conf
local -x VIRTUALENV_SYSTEM_SITE_PACKAGES=1
@@ -496,6 +495,8 @@ python_test() {
local -x PYO3_USE_ABI3_FORWARD_COMPATIBILITY=1
local skip=(
+ # picky cli output test that easily benignly fail (bug #937992)
+ --skip cli_tests
# avoid need for wasm over a single hello world test
--skip integration_wasm_hello_world
# fragile depending on rust version, also wants libpypy*-c.so for pypy