summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-22 06:19:17 +0100
committerSam James <sam@gentoo.org>2023-06-22 06:19:17 +0100
commit6b8bbb9f465e3932e32aa9424599e4eb2b7540cc (patch)
treea06cb0cd90c8ac8a134517819fb935a1213f7cb7 /dev-util
parentvirtual/perl-Module-CoreList: Stabilize 5.202.304.230 arm, #908983 (diff)
downloadgentoo-6b8bbb9f465e3932e32aa9424599e4eb2b7540cc.tar.gz
gentoo-6b8bbb9f465e3932e32aa9424599e4eb2b7540cc.tar.bz2
gentoo-6b8bbb9f465e3932e32aa9424599e4eb2b7540cc.zip
dev-util/meson: drop 1.0.1, 1.1.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/meson/Manifest2
-rw-r--r--dev-util/meson/meson-1.0.1.ebuild121
-rw-r--r--dev-util/meson/meson-1.1.0.ebuild121
3 files changed, 0 insertions, 244 deletions
diff --git a/dev-util/meson/Manifest b/dev-util/meson/Manifest
index 8cdf77e14032..aee94636f8bc 100644
--- a/dev-util/meson/Manifest
+++ b/dev-util/meson/Manifest
@@ -1,3 +1 @@
-DIST meson-1.0.1.tar.gz 2104183 BLAKE2B 23b47a2231da966de8da3032887a81458b795d5c0c1d35cf9e3ea1499f7ddbc28d1cc3ca469052c4b33c51fcf9f92a36dab44da0133d748afdbf4e5b260427f1 SHA512 3d2e2630f9eacf2fd999d5068d82b2a719400a55cfdea5d38253410a3ee74def638ac09622bceb72edf7bc867ae3de6a5f48c1846601e7e4b5afdf3ac9339ebc
-DIST meson-1.1.0.tar.gz 2124254 BLAKE2B 149dedc0e49b72682fa053f27f9a6c2543362539861b4b79ce65ecf4d913e221ac2d63f3b9aa350bd7622851c73be418b804ae1131dd27607eb01218e0204a5e SHA512 b8968becd1de25d8e92ecbe4c3b50694269a463430b41fcf5206f35ac952507b01f316721fb36f8c7940437e35c3588f6a4504f5b8256fa47fd9b0ceb588ae39
DIST meson-1.1.1.tar.gz 2125503 BLAKE2B 295b46d19c8a1d64d326a6c826e2abe11d9768902ed2f8816df18677e7f3f58decc0c660925821825ecd9a4955a65bda8b2aa66a7bb1961810d8f78f92a3fd8a SHA512 c6259d73566d2532b87e8a23951363103f7be2aacdf120e50946273a2fed6b1602104a3ffbfda159138ac8f780d2c3e67a6fe2c8c228b73c1266775491797adb
diff --git a/dev-util/meson/meson-1.0.1.ebuild b/dev-util/meson/meson-1.0.1.ebuild
deleted file mode 100644
index 0a5fa1cdd6f1..000000000000
--- a/dev-util/meson/meson-1.0.1.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 2016-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_PEP517=setuptools
-
-if [[ ${PV} = *9999* ]]; then
- EGIT_REPO_URI="https://github.com/mesonbuild/meson"
- inherit git-r3
-else
- inherit pypi
-
- MY_P=${P/_/}
- S=${WORKDIR}/${MY_P}
-
- if [[ ${PV} != *_rc* ]] ; then
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
- fi
-fi
-
-inherit bash-completion-r1 distutils-r1 toolchain-funcs
-
-DESCRIPTION="Open source build system"
-HOMEPAGE="https://mesonbuild.com/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- test? (
- dev-libs/glib:2
- dev-libs/gobject-introspection
- dev-util/ninja
- dev-vcs/git
- sys-libs/zlib[static-libs(+)]
- virtual/pkgconfig
- )
-"
-RDEPEND="
- virtual/pkgconfig
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.63-xtools-support.patch
-)
-
-python_prepare_all() {
- local disable_unittests=(
- # ASAN and sandbox both want control over LD_PRELOAD
- # https://bugs.gentoo.org/673016
- -e 's/test_generate_gir_with_address_sanitizer/_&/'
-
- # ASAN is unsupported on some targets
- # https://bugs.gentoo.org/692822
- -e 's/test_pch_with_address_sanitizer/_&/'
-
- # https://github.com/mesonbuild/meson/issues/7203
- -e 's/test_templates/_&/'
-
- # Broken due to python2 wrapper
- -e 's/test_python_module/_&/'
- )
-
- sed -i "${disable_unittests[@]}" unittests/*.py || die
-
- # Broken due to python2 script created by python_wrapper_setup
- rm -r "test cases/frameworks/1 boost" || die
-
- distutils-r1_python_prepare_all
-}
-
-src_test() {
- tc-export PKG_CONFIG
- if ${PKG_CONFIG} --exists Qt5Core && ! ${PKG_CONFIG} --exists Qt5Gui; then
- ewarn "Found Qt5Core but not Qt5Gui; skipping tests"
- else
- distutils-r1_src_test
- fi
-}
-
-python_test() {
- (
- # test_meson_installed
- unset PYTHONDONTWRITEBYTECODE
-
- # https://bugs.gentoo.org/687792
- unset PKG_CONFIG
-
- # test_cross_file_system_paths
- unset XDG_DATA_HOME
-
- # 'test cases/unit/73 summary' expects 80 columns
- export COLUMNS=80
-
- # If JAVA_HOME is not set, meson looks for javac in PATH.
- # If javac is in /usr/bin, meson assumes /usr/include is a valid
- # JDK include path. Setting JAVA_HOME works around this broken
- # autodetection. If no JDK is installed, we should end up with an empty
- # value in JAVA_HOME, and the tests should get skipped.
- export JAVA_HOME=$(java-config -O 2>/dev/null)
-
- # Call python3 instead of EPYTHON to satisfy test_meson_uninstalled.
- python3 run_tests.py
- ) || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- insinto /usr/share/vim/vimfiles
- doins -r data/syntax-highlighting/vim/{ftdetect,indent,syntax}
-
- insinto /usr/share/zsh/site-functions
- doins data/shell-completions/zsh/_meson
-
- dobashcomp data/shell-completions/bash/meson
-}
diff --git a/dev-util/meson/meson-1.1.0.ebuild b/dev-util/meson/meson-1.1.0.ebuild
deleted file mode 100644
index c9781cdd78c0..000000000000
--- a/dev-util/meson/meson-1.1.0.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 2016-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-DISTUTILS_USE_PEP517=setuptools
-
-if [[ ${PV} = *9999* ]]; then
- EGIT_REPO_URI="https://github.com/mesonbuild/meson"
- inherit git-r3
-else
- inherit pypi
-
- MY_P=${P/_/}
- S=${WORKDIR}/${MY_P}
-
- if [[ ${PV} != *_rc* ]] ; then
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
- fi
-fi
-
-inherit bash-completion-r1 distutils-r1 toolchain-funcs
-
-DESCRIPTION="Open source build system"
-HOMEPAGE="https://mesonbuild.com/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- test? (
- dev-libs/glib:2
- dev-libs/gobject-introspection
- dev-util/ninja
- dev-vcs/git
- sys-libs/zlib[static-libs(+)]
- virtual/pkgconfig
- )
-"
-RDEPEND="
- virtual/pkgconfig
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.63-xtools-support.patch
-)
-
-python_prepare_all() {
- local disable_unittests=(
- # ASAN and sandbox both want control over LD_PRELOAD
- # https://bugs.gentoo.org/673016
- -e 's/test_generate_gir_with_address_sanitizer/_&/'
-
- # ASAN is unsupported on some targets
- # https://bugs.gentoo.org/692822
- -e 's/test_pch_with_address_sanitizer/_&/'
-
- # https://github.com/mesonbuild/meson/issues/7203
- -e 's/test_templates/_&/'
-
- # Broken due to python2 wrapper
- -e 's/test_python_module/_&/'
- )
-
- sed -i "${disable_unittests[@]}" unittests/*.py || die
-
- # Broken due to python2 script created by python_wrapper_setup
- rm -r "test cases/frameworks/1 boost" || die
-
- distutils-r1_python_prepare_all
-}
-
-src_test() {
- tc-export PKG_CONFIG
- if ${PKG_CONFIG} --exists Qt5Core && ! ${PKG_CONFIG} --exists Qt5Gui; then
- ewarn "Found Qt5Core but not Qt5Gui; skipping tests"
- else
- distutils-r1_src_test
- fi
-}
-
-python_test() {
- (
- # test_meson_installed
- unset PYTHONDONTWRITEBYTECODE
-
- # https://bugs.gentoo.org/687792
- unset PKG_CONFIG
-
- # test_cross_file_system_paths
- unset XDG_DATA_HOME
-
- # 'test cases/unit/73 summary' expects 80 columns
- export COLUMNS=80
-
- # If JAVA_HOME is not set, meson looks for javac in PATH.
- # If javac is in /usr/bin, meson assumes /usr/include is a valid
- # JDK include path. Setting JAVA_HOME works around this broken
- # autodetection. If no JDK is installed, we should end up with an empty
- # value in JAVA_HOME, and the tests should get skipped.
- export JAVA_HOME=$(java-config -O 2>/dev/null)
-
- # Call python3 instead of EPYTHON to satisfy test_meson_uninstalled.
- python3 run_tests.py
- ) || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- insinto /usr/share/vim/vimfiles
- doins -r data/syntax-highlighting/vim/{ftdetect,indent,syntax}
-
- insinto /usr/share/zsh/site-functions
- doins data/shell-completions/zsh/_meson
-
- dobashcomp data/shell-completions/bash/meson
-}