summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn M. Harris Jr. <johnmh@johnmh.me>2024-10-09 09:20:37 -0700
committerYixun Lan <dlan@gentoo.org>2024-10-17 19:39:47 +0800
commit929ffa46741c1dfcba92f6ec0e14886bb2ac95b4 (patch)
tree628ca7ce868c35f8b2f524e5f4f89957dceb4dee /dev-util
parentapp-i18n/ibus: Bump to 1.5.30 (diff)
downloadgentoo-929ffa46741c1dfcba92f6ec0e14886bb2ac95b4.tar.gz
gentoo-929ffa46741c1dfcba92f6ec0e14886bb2ac95b4.tar.bz2
gentoo-929ffa46741c1dfcba92f6ec0e14886bb2ac95b4.zip
dev-util/hyprwayland-scanner: add 0.4.2
Signed-off-by: John M. Harris Jr. <johnmh@johnmh.me> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/hyprwayland-scanner/Manifest1
-rw-r--r--dev-util/hyprwayland-scanner/hyprwayland-scanner-0.4.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/hyprwayland-scanner/Manifest b/dev-util/hyprwayland-scanner/Manifest
index 864f598caa03..9abe87c3ee6c 100644
--- a/dev-util/hyprwayland-scanner/Manifest
+++ b/dev-util/hyprwayland-scanner/Manifest
@@ -1,2 +1,3 @@
DIST hyprwayland-scanner-0.3.10.gh.tar.gz 10039 BLAKE2B 369c2445904480ec9368101056e9712c0583307c1faaea43fed80f17075521371865841c777070a6983d9a84c394c620b0b0ecd53bbd6166f7828e136c0d52eb SHA512 d63f9490d048725a7faa3995e3786190b37db16654293cce16c410c4cfd27e61042a50e6feddc7eda42d67c04bdd7bc19b51f475ddd206ffc5464e762003392b
DIST hyprwayland-scanner-0.4.0.gh.tar.gz 10990 BLAKE2B f138f74b896d39f12b63ea3cea5a8f456821a6ed9e0e6baefd80f70dffb2f9cd1b650adf59a871f8f8055f8ed7cfb05e4631e96352fc137b8acbf1b6cdd93fae SHA512 1b7b0ddea94bd2679150a7a6d80628d1156ae11d6963fe31fd6d7292cb1d9c273830bb4515032d0645649e56b57c2d64c5312b007ea11480bb798ea43582fe9c
+DIST hyprwayland-scanner-0.4.2.gh.tar.gz 11160 BLAKE2B c623319354f8fc9571b27c50b490f579e4054723768da0b1ca90a0b31519b4b709ba3bbdc26e1e911f62131aa7b866f1ab8f257a5e19b7349c15641c6b242e75 SHA512 1f1b73dbb80052484889a075095d76e0fba83a5c91f80d8e5a6167153405337b011c423250aef3feb9270ea641fe8d68966a17d92057215f54e4d8cc67b24c7e
diff --git a/dev-util/hyprwayland-scanner/hyprwayland-scanner-0.4.2.ebuild b/dev-util/hyprwayland-scanner/hyprwayland-scanner-0.4.2.ebuild
new file mode 100644
index 000000000000..c48449c55b2b
--- /dev/null
+++ b/dev-util/hyprwayland-scanner/hyprwayland-scanner-0.4.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake toolchain-funcs
+
+DESCRIPTION="A Hyprland implementation of wayland-scanner, in and for C++"
+HOMEPAGE="https://github.com/hyprwm/hyprwayland-scanner/"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/hyprwm/hyprwayland-scanner.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/hyprwm/hyprwayland-scanner/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND=">=dev-libs/pugixml-1.14"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} == binary ]] && return
+
+ if tc-is-gcc && ver_test $(gcc-version) -lt 13 ; then
+ eerror "Hyprland requires >=sys-devel/gcc-13 to build"
+ eerror "Please upgrade GCC: emerge -v1 sys-devel/gcc"
+ die "GCC version is too old to compile Hyprland!"
+ elif tc-is-clang && ver_test $(clang-version) -lt 16 ; then
+ eerror "Hyprland requires >=sys-devel/clang-16 to build"
+ eerror "Please upgrade Clang: emerge -v1 sys-devel/clang"
+ die "Clang version is too old to compile Hyprland!"
+ fi
+}