summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-12 09:07:41 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-12 10:15:01 +0100
commit9d8607bc3a2e1b6d26319d7bd786a44fddb023e4 (patch)
tree8f6f1e0943cf23e4ff8f260ef90550306dbb6e16 /dev-util
parentapp-admin/awscli: Bump to 1.22.54 (diff)
downloadgentoo-9d8607bc3a2e1b6d26319d7bd786a44fddb023e4.tar.gz
gentoo-9d8607bc3a2e1b6d26319d7bd786a44fddb023e4.tar.bz2
gentoo-9d8607bc3a2e1b6d26319d7bd786a44fddb023e4.zip
dev-util/stripe-mock: Bump to 0.118.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/stripe-mock/Manifest1
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.118.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-util/stripe-mock/Manifest b/dev-util/stripe-mock/Manifest
index c9ffa510b414..f8468ee557ca 100644
--- a/dev-util/stripe-mock/Manifest
+++ b/dev-util/stripe-mock/Manifest
@@ -1,2 +1,3 @@
DIST stripe-mock-0.116.0.tar.gz 631741 BLAKE2B 8b8d3e0db1b0cb9e6f54773ac0a2f340c7a609e147c398b55b3616638163a88e8924d3739150b040eb4068aed142bad7f3de3db3679a8bd111b028286ae0ac68 SHA512 bf6dd3abf0fdf4472047060ed28d6709b9215a7c708e40ee573a7ada4be7af1d68d26000c7f1517b15d04923479f5e5113cc952457e810ca29220284b76dd783
DIST stripe-mock-0.117.0.tar.gz 649146 BLAKE2B c7e51c932f43b012df28cd83a4232e0cf5a4892e60bdf6d6fc5a8e34d1ba480a69b7f86a7bb61eff0509bd22b1ac67e9292daea874aa1a291cac78d1c9b86001 SHA512 2a3b7979180be47bd0ade3f920fc17b5a341e38999cf6492e36a572be4308bc10225b0ba9de0f61d5826b2ae189a2c98f99f89e51235faccadaa00db80dd8d91
+DIST stripe-mock-0.118.0.tar.gz 651234 BLAKE2B b6651dda1ee23ce0143688458fc695f4f3fbaf8a8320228599033e0907bac611de2cc3dfd9845f3c27b5a1a07864ca6aa744d11029b078c25b73fd0a8cf99cb5 SHA512 3fa18acd747bee7e17f8ddbe02dda0dc38b9d2fe332d3606e44a3ad75b9acb5b34bd04aace875b4c1b67e172656d7032def6dd08b364939cf76e58a5cc736015
diff --git a/dev-util/stripe-mock/stripe-mock-0.118.0.ebuild b/dev-util/stripe-mock/stripe-mock-0.118.0.ebuild
new file mode 100644
index 000000000000..0f98e7040d17
--- /dev/null
+++ b/dev-util/stripe-mock/stripe-mock-0.118.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGO_SRC="github.com/stripe/stripe-mock"
+EGO_PN=${EGO_SRC}/...
+inherit golang-build golang-vcs-snapshot
+
+DESCRIPTION="Mock HTTP server that responds like the real Stripe API"
+HOMEPAGE="https://github.com/stripe/stripe-mock"
+SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="MIT ISC BSD-2"
+SLOT="0"
+
+src_install() {
+ golang-build_src_install
+ dobin bin/stripe-mock
+ rm -rf "${D}$(get_golibdir_gopath)" || die
+}