summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2024-04-20 19:59:13 +0200
committerAgostino Sarubbo <ago@gentoo.org>2024-04-20 19:59:13 +0200
commitaecec2e643c714f450dd931c50f772242d8c7549 (patch)
treefaed36d588a4fb20b9355fc3ab03cdc1e454dbf0 /dev-util
parentsys-apps/uam: drop stale live ebuild (diff)
downloadgentoo-aecec2e643c714f450dd931c50f772242d8c7549.tar.gz
gentoo-aecec2e643c714f450dd931c50f772242d8c7549.tar.bz2
gentoo-aecec2e643c714f450dd931c50f772242d8c7549.zip
dev-util/bugbite-cli: version bump to 0.0.10
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/bugbite-cli/Manifest1
-rw-r--r--dev-util/bugbite-cli/bugbite-cli-0.0.10.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/bugbite-cli/Manifest b/dev-util/bugbite-cli/Manifest
index b5d7bf97958e..6dbcac91224c 100644
--- a/dev-util/bugbite-cli/Manifest
+++ b/dev-util/bugbite-cli/Manifest
@@ -1 +1,2 @@
+DIST bugbite-cli-0.0.10.tar.xz 18167676 BLAKE2B 2e193e4bf6eb71bcf349e9ffb11e8816fc6f27b1ae2c174c52a4ccb1f5052760b2f47f3c03a1c7792f2f0d3b63fe7bae2710a112480f7b63e34f5f3aa1dd0e21 SHA512 b481ad5cd22737107084e4a22c866474ef4317572730ce739f4e7f08c2669e9d1bbd0571a0125e30a8a567780545c939d034a53f1589feffe97a08f0cf928c7d
DIST bugbite-cli-0.0.9.tar.xz 18610920 BLAKE2B 0c8a18a65da4535250e17f5f7456bc01c8b135f29f5edb58e2bf66fec22d0408634841d5bbb6d4c000235b994e2473564f8f646ae6e8b9161b9e371ea37dcc41 SHA512 fb2192aefdae469ea641bc2cb2678604b65c4ca88777b93811e3f753fe0e0807fbadb95ec8a0f40cf68ab495788064cdc121e501ae76f177ed04ba760505636e
diff --git a/dev-util/bugbite-cli/bugbite-cli-0.0.10.ebuild b/dev-util/bugbite-cli/bugbite-cli-0.0.10.ebuild
new file mode 100644
index 000000000000..54904ffd4168
--- /dev/null
+++ b/dev-util/bugbite-cli/bugbite-cli-0.0.10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cargo edo shell-completion
+
+DESCRIPTION="A command line tool for bug, issue, and ticket mangling"
+HOMEPAGE="https://github.com/radhermit/bugbite"
+SRC_URI="https://github.com/radhermit/bugbite/releases/download/${P}/${P}.tar.xz"
+LICENSE="0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD BSD-2 Boost-1.0 CC0-1.0 ISC MIT MPL-2.0 Unicode-DFS-2016 Unlicense ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="static test"
+RESTRICT="!test? ( test ) "
+
+BDEPEND="
+ >=virtual/rust-1.75
+ test? ( dev-util/cargo-nextest )
+"
+
+QA_FLAGS_IGNORED="usr/bin/bite"
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]] && use static ; then
+ local rust_target=$( rustc -vV 2>/dev/null | sed -n 's|^host: ||p' )
+ [[ -z ${rust_target} ]] && die "Failed to read host target from rustc!"
+ export RUSTFLAGS="-C target-feature=+crt-static ${RUSTFLAGS}"
+ export static_stuff="--target ${rust_target}"
+ fi
+}
+
+src_configure() {
+ cargo_src_configure ${static_stuff}
+}
+
+src_test() {
+ edo cargo nextest run $(usev !debug '--release') --color always --features test --tests ${static_stuff}
+}
+
+src_install() {
+ cargo_src_install
+
+ doman man/*
+ dofishcomp shell/bite.fish
+ dozshcomp shell/_bite
+ newbashcomp shell/bite.bash bite
+}