summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-12-25 14:44:39 -0600
committerWilliam Hubbs <williamh@gentoo.org>2024-12-25 14:47:06 -0600
commitf52b88ee19279e6373233c533a14f20cb3f510f8 (patch)
tree8b9a4512c2dcf347edf1c08135bf3625c384f60a /dev-util
parentapp-containers/docker: 27.4.1-r1 revbump (diff)
downloadgentoo-f52b88ee19279e6373233c533a14f20cb3f510f8.tar.gz
gentoo-f52b88ee19279e6373233c533a14f20cb3f510f8.tar.bz2
gentoo-f52b88ee19279e6373233c533a14f20cb3f510f8.zip
dev-util/gitlab-cli: add 1.51.0
Closes: https://bugs.gentoo.org/946667 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gitlab-cli/Manifest2
-rw-r--r--dev-util/gitlab-cli/gitlab-cli-1.51.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/gitlab-cli/Manifest b/dev-util/gitlab-cli/Manifest
index 167fd29cca22..7f03d7a2d567 100644
--- a/dev-util/gitlab-cli/Manifest
+++ b/dev-util/gitlab-cli/Manifest
@@ -4,3 +4,5 @@ DIST gitlab-cli-1.46.0-deps.tar.xz 21625028 BLAKE2B c4c5c38f505e0812e2ab5490d506
DIST gitlab-cli-1.46.0.tar.bz2 16845037 BLAKE2B b1bbfffb0968b5245fae91a7ba0c29f7c278de06006a79f8d5b9c64acb577b5cead2a3587eb770a35d5b0fd75fc9917c078918cb51541e677b739d38ec9510e3 SHA512 c6a1a854019f21cb172dba1ce01c8a4e94d6af7ada52c1bf182bb3444fcb8f7d593eb009a2c89c078f09f7abde57443a95d2a81aa11619ebecb75bfb5ace6ada
DIST gitlab-cli-1.48.0-deps.tar.xz 21543860 BLAKE2B 7193a39b845a2afc999100f5936a9a5e8565597b51c37c9717fd38ff4799fba53ba74eb4acf9d02cd6d7247270e794976e8c0e57949881a3183f692cd32dfb96 SHA512 15c294669b61288bf9f23c312b5d29e3fb53c6dd9b2bbc4877bbcb42ad8b06cac1cb5f8b4252749bebb774f5d374b63e9e7ee89e5fefd452a81e6082c0d7091f
DIST gitlab-cli-1.48.0.tar.bz2 16863481 BLAKE2B d7ffaca8b63772dc3394d7205044f2c43c8bb58b08f3e892bd4ab169c10151dd67337847b850b7e625b4d32bf674162851664cfb81af76bb9636432439758f12 SHA512 e59d31b6fb3ebbbe989c1198b9e33bc639a46d68fffa24b5df3c1b4fe8391a5c7a9fb84a7d9dcf1989d63375ef92d964e6474203be31a2fc82509959b28075a2
+DIST gitlab-cli-1.51.0-deps.tar.xz 21574644 BLAKE2B ab3309e6e1bd413a306e3c1aec172b191cd223bee3b941e1e21811951311e477e8d4118f20a89a8ee9a898eaf30d7f5ce8fc30f4eadc7ac07d7a76fe86288361 SHA512 2628b65c1f1c4c9207eba14e3c36656a724bbce48ad371a264d361fe52499eb206b35ebd43eee25e80b896d40250643d3b69dc954b70ef30ff8227fc0658c845
+DIST gitlab-cli-1.51.0.tar.bz2 16865378 BLAKE2B 65091d664ec3a2148c670407c5c92dd2b64d92662255b8ba6f3911d6eb79a55ee9e5c83da2b48615de6bb996aaa361b259b359230070198250d959e2b2060e0e SHA512 dc587d8574c924c2c69502bd6028b40533f662f1ec79f93ef42e78fca41c7cde7c30fd5cbf7cd99f8d3311802048d957553082df16368608815f637d9a362af9
diff --git a/dev-util/gitlab-cli/gitlab-cli-1.51.0.ebuild b/dev-util/gitlab-cli/gitlab-cli-1.51.0.ebuild
new file mode 100644
index 000000000000..7f8a1eddbb23
--- /dev/null
+++ b/dev-util/gitlab-cli/gitlab-cli-1.51.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_COMMIT=1481403b25a7e54dea0a83b808c0bb4936283cfd
+
+DESCRIPTION="the official gitlab command line interface"
+HOMEPAGE="https://gitlab.com/gitlab-org/cli"
+SRC_URI="https://gitlab.com/gitlab-org/cli/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+S="${WORKDIR}/cli-v${PV}-${GIT_COMMIT}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND=">=dev-lang/go-1.23.2"
+
+# tests communicate with gitlab.com and require a personal access token
+RESTRICT="test"
+
+src_compile() {
+ emake \
+ GLAB_VERSION=v${PV} \
+ build manpage
+}
+
+src_install() {
+ dobin bin/glab
+ dodoc README.md
+ doman share/man/man1/*
+}