summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-10-17 20:22:10 -0700
committerZac Medico <zmedico@gentoo.org>2020-10-17 20:51:17 -0700
commitf7a79527bcf3eaac3ae56e95c42bbb68201842c1 (patch)
tree1cd2fbb15220b20c4ff8afb1db7bb928b221dd09 /dev-util
parentapp-admin/glance: VICTORIA (diff)
downloadgentoo-f7a79527bcf3eaac3ae56e95c42bbb68201842c1.tar.gz
gentoo-f7a79527bcf3eaac3ae56e95c42bbb68201842c1.tar.bz2
gentoo-f7a79527bcf3eaac3ae56e95c42bbb68201842c1.zip
dev-util/ostree: Bump to version 2020.7
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/ostree/Manifest1
-rw-r--r--dev-util/ostree/metadata.xml2
-rw-r--r--dev-util/ostree/ostree-2020.7.ebuild99
3 files changed, 102 insertions, 0 deletions
diff --git a/dev-util/ostree/Manifest b/dev-util/ostree/Manifest
index a0d1025bb602..dbea5d92d2a4 100644
--- a/dev-util/ostree/Manifest
+++ b/dev-util/ostree/Manifest
@@ -1,2 +1,3 @@
DIST ostree-2019.5.tar.xz 1972452 BLAKE2B a8b015118855b8b0097f535ac074aeffc599c3f6f654967043e8e4de339d2a51e85ad1b4b3f3b22e18d39235e6ad9c1973334a2c4fc9b5c694f2ff40d68ae703 SHA512 27150802ed9af16e698ed163f6ad235f0f99a1410df52b4b1e266585fe665880c0b9490bf245b5593cb277007b7229d808be7403dd964c58aded6e567349c912
DIST ostree-2020.6.tar.xz 2014456 BLAKE2B 97d84c6838993edfbabb598bce800332ab1c8b22c0431839f7129f2f57afdd71c1b8ea8b8d6c1dc2cbf8d7f6828d624394b5e8c533f7a98eb1b1c3aeedff92cf SHA512 1d8f8ccaa3e543a6f494d3be2a3651ad340846f0c314e003955260b7bd1d8c0421acf102ec2ca6580379c354bf4cfac0940e4e95b724b7aaf9dc8116085aa538
+DIST ostree-2020.7.tar.xz 2022004 BLAKE2B 2113117ce8553b7ffcfea17e1cb3a9c697d39b4933b48c30729af72fc833bb00f39e7e3a327efeebaac1df307b1f62ccf16a7772e12ad77737e2219c87623824 SHA512 f42dca3c9e1810c0421ab99588f27c625733b71ef811534b66e0c0c4afafbad5bf475e08feaf87c2f8414c38f127fd344adbb57a4b75001077aedbfe92af3706
diff --git a/dev-util/ostree/metadata.xml b/dev-util/ostree/metadata.xml
index da0ad42b602f..6aff9bd9b75d 100644
--- a/dev-util/ostree/metadata.xml
+++ b/dev-util/ostree/metadata.xml
@@ -32,10 +32,12 @@
<use>
<flag name="archive">Use libarchive</flag>
<flag name="dracut">Install dracut module</flag>
+ <flag name="gpg">Enable GPG support</flag>
<flag name="grub">Enable grub configuration generator</flag>
<flag name="http2">Use http2</flag>
<flag name="httpd">Enable ostree trivial-httpd entrypoint</flag>
<flag name="libmount">Use libmount</flag>
+ <flag name="sodium">Use libsodium for ed25519</flag>
<flag name="soup">Use libsoup for networking</flag>
</use>
<upstream>
diff --git a/dev-util/ostree/ostree-2020.7.ebuild b/dev-util/ostree/ostree-2020.7.ebuild
new file mode 100644
index 000000000000..60fe10a4ee78
--- /dev/null
+++ b/dev-util/ostree/ostree-2020.7.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+DESCRIPTION="Operating system and container binary deployment and upgrades"
+HOMEPAGE="https://ostreedev.github.io/ostree/"
+SRC_URI="https://github.com/ostreedev/ostree/releases/download/v${PV}/lib${P}.tar.xz -> ${P}.tar.xz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="LGPL-2+"
+SLOT="0"
+
+IUSE="archive curl doc dracut gnutls +gpg grub http2 httpd introspection libmount selinux sodium ssl soup systemd zeroconf"
+RESTRICT="test"
+REQUIRED_USE="httpd? ( || ( curl soup ) )"
+
+COMMON_DEPEND="
+ archive? ( app-arch/libarchive )
+ app-arch/xz-utils
+ curl? ( net-misc/curl )
+ soup? ( net-libs/libsoup )
+ dev-libs/libassuan
+ dev-libs/glib:2
+ dracut? ( sys-kernel/dracut )
+ gpg? (
+ app-crypt/gpgme
+ dev-libs/libgpg-error
+ )
+ grub? ( sys-boot/grub:2= )
+ introspection? ( dev-libs/gobject-introspection )
+ ssl? (
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( dev-libs/openssl:0= ) )
+ >=sys-fs/fuse-2.9.2:0
+ sys-libs/zlib
+ libmount? ( sys-apps/util-linux )
+ selinux? ( sys-libs/libselinux )
+ sodium? ( >=dev-libs/libsodium-1.0.14 )
+ systemd? ( sys-apps/systemd:0= )
+ zeroconf? ( net-dns/avahi[dbus] )"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ doc? ( dev-util/gtk-doc )"
+
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ sys-devel/flex
+ sys-devel/bison
+ virtual/pkgconfig"
+
+S="${WORKDIR}/lib${P}"
+
+src_prepare() {
+ sed -Ee 's:(XSLT_STYLESHEET = ).*:\1/usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl:' \
+ -i Makefile.in Makefile-man.am || die
+ eautoreconf
+ default
+}
+
+src_configure() {
+ local econfargs=(
+ --enable-man
+ --enable-shared
+ $(use_with archive libarchive)
+ $(use_with curl)
+ $(use_with dracut)
+ $(use_enable doc gtk-doc)
+ $(usex introspection --enable-introspection={,} yes no)
+ $(use_with gpg gpgme)
+ $(use_enable http2)
+ $(use_enable httpd trivial-httpd-cmdline)
+ $(use_with selinux )
+ $(use_with soup)
+ $(use_with libmount)
+ $(use ssl && { use gnutls && echo --with-crypto=gnutls || echo --with-crypto=openssl; })
+ $(use_with sodium ed25519-libsodium)
+ $(use_with systemd libsystemd)
+ $(use_with zeroconf avahi)
+ )
+
+ if use systemd; then
+ econfargs+=(--with-systemdsystemunitdir="$(systemd_get_systemunitdir)")
+ fi
+
+ unset ${!XDG_*} #657346 g-ir-scanner sandbox violation
+ econf ${econfargs[*]}
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+ rm -f "${ED}/etc/grub.d/15_ostree"
+}