summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-10-26 01:13:27 +0100
committerMarek Szuba <marecki@gentoo.org>2023-10-26 01:14:05 +0100
commitcd2362866dcc3dfa6a3e91a2fb3748489229b9f8 (patch)
tree8cb05818ea924c9844f7e25b102d07c8b9701bdc /dev-vcs/pre-commit
parentdev-python/mkdocstrings: update test dependencies (diff)
downloadgentoo-cd2362866dcc3dfa6a3e91a2fb3748489229b9f8.tar.gz
gentoo-cd2362866dcc3dfa6a3e91a2fb3748489229b9f8.tar.bz2
gentoo-cd2362866dcc3dfa6a3e91a2fb3748489229b9f8.zip
dev-vcs/pre-commit: add 3.5.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-vcs/pre-commit')
-rw-r--r--dev-vcs/pre-commit/Manifest1
-rw-r--r--dev-vcs/pre-commit/pre-commit-3.5.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-vcs/pre-commit/Manifest b/dev-vcs/pre-commit/Manifest
index 1ce7141a1a0d..ce5941212686 100644
--- a/dev-vcs/pre-commit/Manifest
+++ b/dev-vcs/pre-commit/Manifest
@@ -1 +1,2 @@
DIST pre-commit-3.3.3.gh.tar.gz 267281 BLAKE2B dbe3b90dd3808d24084ede3e9bd76ddc5b070d43bd70b3fa813f8e8e95875a178b86632208463c50a3d68868f2dd9d888e00e7bf3aeba3f3b78c7cd39b514270 SHA512 d126bead7ffa2c72213a894c82bc45d0bce8b508cf7190e7b7d56c667b5d3ebff80eedf7ecb4bb1e01923ef9a43878b73356fda866614d8cbcc8f241ee9e01f7
+DIST pre-commit-3.5.0.gh.tar.gz 268906 BLAKE2B 7585aae950f63845cf132b3472662f19f87942b886687551fbf69e4adb20513304d2c4d399c12619e6c7f9aeab0a6a57c3fe3cd271a29470bedc9480b3b34256 SHA512 c7504fa2d3ba70def3361af0fcc2f7a5454325125e27f44fbaa60906f1ac35b0fa1b646eaf326cb04d4d042ecb6786fbb8e9166099df1e687fa2a64a8113c244
diff --git a/dev-vcs/pre-commit/pre-commit-3.5.0.ebuild b/dev-vcs/pre-commit/pre-commit-3.5.0.ebuild
new file mode 100644
index 000000000000..e6d46da41754
--- /dev/null
+++ b/dev-vcs/pre-commit/pre-commit-3.5.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# py3.12 blocked by nodeenv
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
+HOMEPAGE="https://pre-commit.com/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+
+RDEPEND="dev-vcs/git
+ $(python_gen_cond_dep '
+ >=dev-python/cfgv-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/identify-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/nodeenv-0.11.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.10.0[${PYTHON_USEDEP}]
+ ')"
+# coreutils requirement: see Bug #885559
+BDEPEND="test? (
+ $(python_gen_cond_dep '
+ dev-python/pytest-env[${PYTHON_USEDEP}]
+ dev-python/re-assert[${PYTHON_USEDEP}]
+ ')
+ sys-apps/coreutils[-multicall]
+)"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.1-tests_git_file_transport.patch
+)
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
+
+# The former two require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
+# and while some of them do include "skip if not found" logic, most of them do not.
+# The latter consistently fail with
+# Calling "git rev-parse" fails with "fatal: not a git repository (or any of the parent directories): .git".
+# including with the sandbox disabled.
+EPYTEST_DESELECT=(
+ tests/languages/
+ tests/repository_test.py
+ tests/main_test.py::test_all_cmds
+ tests/main_test.py::test_hook_stage_migration
+ tests/main_test.py::test_try_repo
+)
+
+distutils_enable_tests pytest