summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-01-09 22:41:42 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-01-09 22:45:48 +0100
commit9420d8550979bfaea8060c085a2e031414258369 (patch)
tree5031de6355501266e105cb62baf49e43bafaa439 /dev-vcs/qgit/qgit-2.10.ebuild
parentdev-ml/luv: fix ocamlopt dep (diff)
downloadgentoo-9420d8550979bfaea8060c085a2e031414258369.tar.gz
gentoo-9420d8550979bfaea8060c085a2e031414258369.tar.bz2
gentoo-9420d8550979bfaea8060c085a2e031414258369.zip
dev-vcs/qgit: 2.10 version bump
See also: https://github.com/tibirna/qgit/releases/tag/qgit-2.10 Closes: https://bugs.gentoo.org/830877 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-vcs/qgit/qgit-2.10.ebuild')
-rw-r--r--dev-vcs/qgit/qgit-2.10.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-vcs/qgit/qgit-2.10.ebuild b/dev-vcs/qgit/qgit-2.10.ebuild
new file mode 100644
index 000000000000..f593607c918c
--- /dev/null
+++ b/dev-vcs/qgit/qgit-2.10.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="Qt GUI for git repositories"
+HOMEPAGE="https://github.com/tibirna/qgit"
+SRC_URI="https://github.com/tibirna/qgit/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}
+ dev-vcs/git
+"
+
+DOCS=( README.adoc )