summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2021-11-24 17:50:03 +0800
committerYixun Lan <dlan@gentoo.org>2021-11-24 17:50:12 +0800
commitb269c53e4fc32b7dfedf6ab9a8da3684c61e4502 (patch)
tree07fa4ef2aaa16fde5cdd8bd0e81ee6f7262148de /dev-vcs/stgit
parentdev-ruby/execjs: Stabilize 2.8.1 arm, #827070 (diff)
downloadgentoo-b269c53e4fc32b7dfedf6ab9a8da3684c61e4502.tar.gz
gentoo-b269c53e4fc32b7dfedf6ab9a8da3684c61e4502.tar.bz2
gentoo-b269c53e4fc32b7dfedf6ab9a8da3684c61e4502.zip
dev-vcs/stgit: version bump, 1.4
Closes: https://bugs.gentoo.org/820560 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-vcs/stgit')
-rw-r--r--dev-vcs/stgit/Manifest1
-rw-r--r--dev-vcs/stgit/stgit-1.4.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-vcs/stgit/Manifest b/dev-vcs/stgit/Manifest
index d12b8d07cc11..7b1184d022e8 100644
--- a/dev-vcs/stgit/Manifest
+++ b/dev-vcs/stgit/Manifest
@@ -1 +1,2 @@
DIST stgit-1.1.tar.gz 313862 BLAKE2B 2d15ba7c2f55ff1211f0d9a3002878102f5023e897d0830daa688a2af8c6a386ec0cf076c728b6f45650ee3382379a32fb4efb25d0da3b28302f158dfca6ef62 SHA512 917c645f219b2725d1e88186674a6184c96f1457d5c7722b4da17931d963f0fe0c675cdaaca435ba7405ba498d6db9a01c9f554d1aa3093cc3205d224d9d9759
+DIST stgit-1.4.tar.gz 390734 BLAKE2B a2c8b6848cacd743022318ebf9a0512c6bd02a2b8c864db2270e5075c82dfd9e6037a3a79978b2061487bf040864077b0f7836c66986d82ff3eb902331589d87 SHA512 5251dc26a7c64dcc83021399f95ea911d6b65cfb2ee5c016c886447740ed48b66d3f0bd92a45b4aed40ae2e77dfe6ba62336dbba6773a1879ab749c95bb99b4b
diff --git a/dev-vcs/stgit/stgit-1.4.ebuild b/dev-vcs/stgit/stgit-1.4.ebuild
new file mode 100644
index 000000000000..06367525ebb8
--- /dev/null
+++ b/dev-vcs/stgit/stgit-1.4.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Manage a stack of patches using GIT as a backend"
+HOMEPAGE="https://stacked-git.github.io"
+UPSTREAM_VER=
+[[ -n ${UPSTREAM_VER} ]] && \
+ UPSTREAM_PATCHSET_URI="https://dev.gentoo.org/~dlan/distfiles/${P}-upstream-patches-${UPSTREAM_VER}.tar.xz"
+
+SRC_URI="https://github.com/ctmarinas/stgit/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ ${UPSTREAM_PATCHSET_URI}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND=">=dev-vcs/git-1.6.3.3"
+
+# NOTE: It seems to be quite important which asciidoc version to use.
+# So keep an eye on it for the future.
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/asciidoc
+ app-text/xmlto
+ dev-lang/perl
+ )"
+
+pkg_setup() {
+ if ! use doc; then
+ echo
+ ewarn "Manpages will not be built and installed."
+ ewarn "Enable the 'doc' useflag, if you want them."
+ echo
+ fi
+}
+
+python_prepare_all() {
+ # Upstream's patchset
+ [[ -n ${UPSTREAM_VER} ]] && \
+ eapply "${WORKDIR}"/patches-upstream
+
+ # this will be a noop, as we are working with a tarball,
+ # but throws git errors --> just get rid of it
+ echo "version=\"${PV}\"" > "${S}"/stgit/builtin_version.py
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+
+ # bug 526468
+ if use doc; then
+ emake htmldir="${EPREFIX}/usr/share/doc/${PF}/html/" \
+ mandir="${EPREFIX}/usr/share/man/" \
+ doc
+ fi
+}
+
+src_install() {
+ if use doc; then
+ emake DESTDIR="${D}" \
+ htmldir="${EPREFIX}/usr/share/doc/${PF}/html/" \
+ mandir="${EPREFIX}/usr/share/man/" \
+ install-doc install-html
+ fi
+
+ distutils-r1_src_install
+
+ newbashcomp completion/stgit.bash 'stg'
+}