summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-04-22 17:47:10 -0400
committerMike Gilbert <floppym@gentoo.org>2022-04-22 17:47:10 -0400
commit1b90705e46af2e19c635f331342f827fc09dfc80 (patch)
tree6cba2b0767b009d3cde921f2d925b63893bcca38 /dev-vcs
parentprofiles/arch/arm: mask freetype[svg] where no Rust (diff)
downloadgentoo-1b90705e46af2e19c635f331342f827fc09dfc80.tar.gz
gentoo-1b90705e46af2e19c635f331342f827fc09dfc80.tar.bz2
gentoo-1b90705e46af2e19c635f331342f827fc09dfc80.zip
dev-vcs/rcs: addpredict / for tests
Closes: https://bugs.gentoo.org/840173 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/rcs/rcs-5.10.0.ebuild10
-rw-r--r--dev-vcs/rcs/rcs-5.10.1.ebuild8
2 files changed, 17 insertions, 1 deletions
diff --git a/dev-vcs/rcs/rcs-5.10.0.ebuild b/dev-vcs/rcs/rcs-5.10.0.ebuild
index 7195ab87aef1..5bd7347fc901 100644
--- a/dev-vcs/rcs/rcs-5.10.0.ebuild
+++ b/dev-vcs/rcs/rcs-5.10.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -41,6 +41,14 @@ src_test() {
emake check
}
+src_test() {
+ # Tests attempt to call rcs commands on /dev/null and /tmp.
+ # https://bugs.gentoo.org/840173
+ local -x SANDBOX_PREDICT=${SANDBOX_PREDICT}
+ addpredict /
+ default
+}
+
src_install() {
emake DESTDIR="${D}" install
diff --git a/dev-vcs/rcs/rcs-5.10.1.ebuild b/dev-vcs/rcs/rcs-5.10.1.ebuild
index ac5f14633fd8..d004ccb4c1a6 100644
--- a/dev-vcs/rcs/rcs-5.10.1.ebuild
+++ b/dev-vcs/rcs/rcs-5.10.1.ebuild
@@ -32,6 +32,14 @@ src_configure() {
econf
}
+src_test() {
+ # Tests attempt to call rcs commands on /dev/null and /tmp.
+ # https://bugs.gentoo.org/840173
+ local -x SANDBOX_PREDICT=${SANDBOX_PREDICT}
+ addpredict /
+ default
+}
+
src_install() {
emake DESTDIR="${D}" install