summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-19 02:43:06 +0100
committerSam James <sam@gentoo.org>2022-08-19 02:43:06 +0100
commit71e80ba67621b7f95a5859af2a5adec5acc5fd14 (patch)
tree9a07757ab58736bfc9f3babc600ee8b3e343ab5d /dev-vcs
parentdev-python/pyupgrade: new package, add 2.37.3 (diff)
downloadgentoo-71e80ba67621b7f95a5859af2a5adec5acc5fd14.tar.gz
gentoo-71e80ba67621b7f95a5859af2a5adec5acc5fd14.tar.bz2
gentoo-71e80ba67621b7f95a5859af2a5adec5acc5fd14.zip
dev-vcs/git: rebase Darwin patch
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git/files/git-2.37.2-darwin-prefix-gettext.patch22
-rw-r--r--dev-vcs/git/git-2.37.2.ebuild2
-rw-r--r--dev-vcs/git/git-9999-r1.ebuild2
-rw-r--r--dev-vcs/git/git-9999-r2.ebuild2
-rw-r--r--dev-vcs/git/git-9999-r3.ebuild2
-rw-r--r--dev-vcs/git/git-9999.ebuild2
6 files changed, 27 insertions, 5 deletions
diff --git a/dev-vcs/git/files/git-2.37.2-darwin-prefix-gettext.patch b/dev-vcs/git/files/git-2.37.2-darwin-prefix-gettext.patch
new file mode 100644
index 000000000000..af267347e65e
--- /dev/null
+++ b/dev-vcs/git/files/git-2.37.2-darwin-prefix-gettext.patch
@@ -0,0 +1,22 @@
+Don't examine outside of the prefix for gettext on macOS/Darwin.
+https://bugs.gentoo.org/757309
+--- a/config.mak.uname
++++ b/config.mak.uname
+@@ -148,17 +148,6 @@ ifeq ($(uname_S),Darwin)
+ HAVE_NS_GET_EXECUTABLE_PATH = YesPlease
+ CSPRNG_METHOD = arc4random
+
+- # Workaround for `gettext` being keg-only and not even being linked via
+- # `brew link --force gettext`, should be obsolete as of
+- # https://github.com/Homebrew/homebrew-core/pull/53489
+- ifeq ($(shell test -d /usr/local/opt/gettext/ && echo y),y)
+- BASIC_CFLAGS += -I/usr/local/include -I/usr/local/opt/gettext/include
+- BASIC_LDFLAGS += -L/usr/local/lib -L/usr/local/opt/gettext/lib
+- ifeq ($(shell test -x /usr/local/opt/gettext/bin/msgfmt && echo y),y)
+- MSGFMT = /usr/local/opt/gettext/bin/msgfmt
+- endif
+- endif
+-
+ # The builtin FSMonitor on MacOS builds upon Simple-IPC. Both require
+ # Unix domain sockets and PThreads.
+ ifndef NO_PTHREADS
diff --git a/dev-vcs/git/git-2.37.2.ebuild b/dev-vcs/git/git-2.37.2.ebuild
index 70bd35f67fb0..cdfdd0b66a85 100644
--- a/dev-vcs/git/git-2.37.2.ebuild
+++ b/dev-vcs/git/git-2.37.2.ebuild
@@ -265,7 +265,7 @@ src_prepare() {
if use prefix ; then
# bug #757309
- eapply "${FILESDIR}"/git-2.31.0-darwin-prefix-gettext.patch
+ eapply "${FILESDIR}"/git-2.37.2-darwin-prefix-gettext.patch
fi
sed -i \
diff --git a/dev-vcs/git/git-9999-r1.ebuild b/dev-vcs/git/git-9999-r1.ebuild
index cf66a5432c9c..a3a70228f500 100644
--- a/dev-vcs/git/git-9999-r1.ebuild
+++ b/dev-vcs/git/git-9999-r1.ebuild
@@ -258,7 +258,7 @@ src_prepare() {
if use prefix ; then
# bug #757309
- eapply "${FILESDIR}"/git-2.31.0-darwin-prefix-gettext.patch
+ eapply "${FILESDIR}"/git-2.37.2-darwin-prefix-gettext.patch
fi
sed -i \
diff --git a/dev-vcs/git/git-9999-r2.ebuild b/dev-vcs/git/git-9999-r2.ebuild
index cf66a5432c9c..a3a70228f500 100644
--- a/dev-vcs/git/git-9999-r2.ebuild
+++ b/dev-vcs/git/git-9999-r2.ebuild
@@ -258,7 +258,7 @@ src_prepare() {
if use prefix ; then
# bug #757309
- eapply "${FILESDIR}"/git-2.31.0-darwin-prefix-gettext.patch
+ eapply "${FILESDIR}"/git-2.37.2-darwin-prefix-gettext.patch
fi
sed -i \
diff --git a/dev-vcs/git/git-9999-r3.ebuild b/dev-vcs/git/git-9999-r3.ebuild
index cf66a5432c9c..a3a70228f500 100644
--- a/dev-vcs/git/git-9999-r3.ebuild
+++ b/dev-vcs/git/git-9999-r3.ebuild
@@ -258,7 +258,7 @@ src_prepare() {
if use prefix ; then
# bug #757309
- eapply "${FILESDIR}"/git-2.31.0-darwin-prefix-gettext.patch
+ eapply "${FILESDIR}"/git-2.37.2-darwin-prefix-gettext.patch
fi
sed -i \
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index cf66a5432c9c..a3a70228f500 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -258,7 +258,7 @@ src_prepare() {
if use prefix ; then
# bug #757309
- eapply "${FILESDIR}"/git-2.31.0-darwin-prefix-gettext.patch
+ eapply "${FILESDIR}"/git-2.37.2-darwin-prefix-gettext.patch
fi
sed -i \