summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-04-02 23:15:39 +0100
committerMarek Szuba <marecki@gentoo.org>2023-04-02 23:19:48 +0100
commit76ebd8447b4ed2a2c3e638475fb0764f8fd236a2 (patch)
tree2c80a96b65c0a2dacc316d442f744952be57f781 /dev-vcs
parentnet-analyzer/nessus-bin: add 10.5.1, drop 10.5.0 (diff)
downloadgentoo-76ebd8447b4ed2a2c3e638475fb0764f8fd236a2.tar.gz
gentoo-76ebd8447b4ed2a2c3e638475fb0764f8fd236a2.tar.bz2
gentoo-76ebd8447b4ed2a2c3e638475fb0764f8fd236a2.zip
dev-vcs/git-machete: add 3.16.2
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-machete/Manifest1
-rw-r--r--dev-vcs/git-machete/git-machete-3.16.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-vcs/git-machete/Manifest b/dev-vcs/git-machete/Manifest
index e026be5a1df7..6168e7501198 100644
--- a/dev-vcs/git-machete/Manifest
+++ b/dev-vcs/git-machete/Manifest
@@ -1,2 +1,3 @@
DIST git-machete-3.14.3.gh.tar.gz 1397234 BLAKE2B 827d3234260461d5cba6b192767e9923b79cc70afb0e7d0bd24e3f307559e3c0774499b34651dd6da7e52157c18becb69c15de9246b99bb35d47104787e6164e SHA512 a4e6015832b4fefa48b75dbd2f3aa50f53788c3a612beada971c0da9da722d49b48e891ddfa3f7d6c91ed4d461b16504ecab9f64b4da84d319b08bb06b1ee8c2
DIST git-machete-3.16.1.gh.tar.gz 1402344 BLAKE2B 4a2c8e473b1e92669e8db7e09850dc8361a110e0f4066fa76fcc6b27fb5c78b034a83f3c6543a2358dd90b86963fefee659c6889b426b496bb4665b8bb056346 SHA512 b2c35da8b5785ac78d81e0782daa59e1ca9f0ae8083dcacd9304f57d916280d604ab9f8d50c5a9ebb1a88ae4d195e40ce8c686316b8de8f62a13d3009feca330
+DIST git-machete-3.16.2.gh.tar.gz 1579273 BLAKE2B d2ed484c13738b7d27fe8f3f9639afbae87bb419e6a2ced933783852c965e9057147adec1d0cb69148f1952939297a8834821fb62b75e9a077e4947f73625371 SHA512 8168f4860ca5462f4acc2c8bc6459e51be5a20d2de4e2c08b5315ce11436b6ae1191975e9858fe1f0b8a4bf4a3a512f45a358a3828437a49f20abc49d68d1375
diff --git a/dev-vcs/git-machete/git-machete-3.16.2.ebuild b/dev-vcs/git-machete/git-machete-3.16.2.ebuild
new file mode 100644
index 000000000000..9964c2ef2ad2
--- /dev/null
+++ b/dev-vcs/git-machete/git-machete-3.16.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Probably the sharpest git repo organizer & rebase/merge workflow automation tool"
+HOMEPAGE="https://github.com/VirtusLab/git-machete https://pypi.org/project/git-machete/"
+# No tests in PyPI tarballs
+SRC_URI="https://github.com/VirtusLab/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="dev-vcs/git"
+BDEPEND="test? (
+ >=dev-python/pytest-mock-3.8.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.5.0[${PYTHON_USEDEP}]
+)"
+
+DOCS=( CONTRIBUTING.md README.md )
+
+distutils_enable_sphinx docs/source dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+
+ newbashcomp completion/${PN}.completion.bash ${PN}
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completion/${PN}.fish
+
+ insinto /usr/share/zsh/site-functions
+ newins completion/${PN}.completion.zsh _${PN}
+}