summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-12-06 16:08:43 +0000
committerSam James <sam@gentoo.org>2024-12-06 16:09:38 +0000
commit77806c722011aa573e83f7a7c79b19cec0a7e168 (patch)
treed753d3126200d4665c3c1acbec43c68417026b9f /dev-vcs
parentdev-vcs/git: pass -std=gnu17 conditionally (diff)
downloadgentoo-77806c722011aa573e83f7a7c79b19cec0a7e168.tar.gz
gentoo-77806c722011aa573e83f7a7c79b19cec0a7e168.tar.bz2
gentoo-77806c722011aa573e83f7a7c79b19cec0a7e168.zip
dev-vcs/git: drop -std=gnu17 for live
Fixed in live. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git/git-9999-r1.ebuild5
-rw-r--r--dev-vcs/git/git-9999-r2.ebuild5
-rw-r--r--dev-vcs/git/git-9999-r3.ebuild5
-rw-r--r--dev-vcs/git/git-9999.ebuild5
4 files changed, 4 insertions, 16 deletions
diff --git a/dev-vcs/git/git-9999-r1.ebuild b/dev-vcs/git/git-9999-r1.ebuild
index 9701a056aae7..17a8afd1ac8b 100644
--- a/dev-vcs/git/git-9999-r1.ebuild
+++ b/dev-vcs/git/git-9999-r1.ebuild
@@ -8,7 +8,7 @@ GENTOO_DEPEND_ON_PERL=no
# bug #329479: git-remote-testgit is not multiple-version aware
PYTHON_COMPAT=( python3_{10..13} )
-inherit flag-o-matic toolchain-funcs perl-module bash-completion-r1 optfeature plocale python-single-r1 systemd
+inherit toolchain-funcs perl-module bash-completion-r1 optfeature plocale python-single-r1 systemd
PLOCALES="bg ca de es fr is it ko pt_PT ru sv vi zh_CN"
@@ -323,9 +323,6 @@ git_emake() {
}
src_configure() {
- # https://lore.kernel.org/git/87ed3apy2u.fsf@gentoo.org/
- append-cflags $(test-flags-CC -std=gnu17)
-
exportmakeopts
}
diff --git a/dev-vcs/git/git-9999-r2.ebuild b/dev-vcs/git/git-9999-r2.ebuild
index 9701a056aae7..17a8afd1ac8b 100644
--- a/dev-vcs/git/git-9999-r2.ebuild
+++ b/dev-vcs/git/git-9999-r2.ebuild
@@ -8,7 +8,7 @@ GENTOO_DEPEND_ON_PERL=no
# bug #329479: git-remote-testgit is not multiple-version aware
PYTHON_COMPAT=( python3_{10..13} )
-inherit flag-o-matic toolchain-funcs perl-module bash-completion-r1 optfeature plocale python-single-r1 systemd
+inherit toolchain-funcs perl-module bash-completion-r1 optfeature plocale python-single-r1 systemd
PLOCALES="bg ca de es fr is it ko pt_PT ru sv vi zh_CN"
@@ -323,9 +323,6 @@ git_emake() {
}
src_configure() {
- # https://lore.kernel.org/git/87ed3apy2u.fsf@gentoo.org/
- append-cflags $(test-flags-CC -std=gnu17)
-
exportmakeopts
}
diff --git a/dev-vcs/git/git-9999-r3.ebuild b/dev-vcs/git/git-9999-r3.ebuild
index 9701a056aae7..17a8afd1ac8b 100644
--- a/dev-vcs/git/git-9999-r3.ebuild
+++ b/dev-vcs/git/git-9999-r3.ebuild
@@ -8,7 +8,7 @@ GENTOO_DEPEND_ON_PERL=no
# bug #329479: git-remote-testgit is not multiple-version aware
PYTHON_COMPAT=( python3_{10..13} )
-inherit flag-o-matic toolchain-funcs perl-module bash-completion-r1 optfeature plocale python-single-r1 systemd
+inherit toolchain-funcs perl-module bash-completion-r1 optfeature plocale python-single-r1 systemd
PLOCALES="bg ca de es fr is it ko pt_PT ru sv vi zh_CN"
@@ -323,9 +323,6 @@ git_emake() {
}
src_configure() {
- # https://lore.kernel.org/git/87ed3apy2u.fsf@gentoo.org/
- append-cflags $(test-flags-CC -std=gnu17)
-
exportmakeopts
}
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index 9701a056aae7..17a8afd1ac8b 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -8,7 +8,7 @@ GENTOO_DEPEND_ON_PERL=no
# bug #329479: git-remote-testgit is not multiple-version aware
PYTHON_COMPAT=( python3_{10..13} )
-inherit flag-o-matic toolchain-funcs perl-module bash-completion-r1 optfeature plocale python-single-r1 systemd
+inherit toolchain-funcs perl-module bash-completion-r1 optfeature plocale python-single-r1 systemd
PLOCALES="bg ca de es fr is it ko pt_PT ru sv vi zh_CN"
@@ -323,9 +323,6 @@ git_emake() {
}
src_configure() {
- # https://lore.kernel.org/git/87ed3apy2u.fsf@gentoo.org/
- append-cflags $(test-flags-CC -std=gnu17)
-
exportmakeopts
}