summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-10 10:54:26 +0100
committerSam James <sam@gentoo.org>2023-06-10 11:24:15 +0100
commitfae3e3b3eeec2d252ad42afeba11ac8ffeb70c42 (patch)
treef1e6055d177cb7f93f140e224a36a7bf59e525f1 /eclass
parentxorg-3.eclass: drop dead prefix targets (diff)
downloadgentoo-fae3e3b3eeec2d252ad42afeba11ac8ffeb70c42.tar.gz
gentoo-fae3e3b3eeec2d252ad42afeba11ac8ffeb70c42.tar.bz2
gentoo-fae3e3b3eeec2d252ad42afeba11ac8ffeb70c42.zip
xorg-3.eclass: cleanup XORG_EAUTORECONF further
The current/previous logic is: * if `XORG_EAUTORECONF` is explicitly no, just elibtoolize. * if `XORG_EAUTORECONF` is yes/unset, automagic it based on configure.{ac,in} presence * if `XORG_EAUTORECONF` is unset, autoreconf I don't see the point in the automagic, so clean it up. At best, it papered over broken ebuilds. (And it's also dangerous if the deps aren't guaranteed to be installed.) Closes: https://github.com/gentoo/gentoo/pull/31279 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'eclass')
-rw-r--r--eclass/xorg-3.eclass8
1 files changed, 5 insertions, 3 deletions
diff --git a/eclass/xorg-3.eclass b/eclass/xorg-3.eclass
index 74ba29657e64..e0b26acca0b0 100644
--- a/eclass/xorg-3.eclass
+++ b/eclass/xorg-3.eclass
@@ -273,9 +273,11 @@ xorg-3_src_unpack() {
xorg-3_reconf_source() {
debug-print-function ${FUNCNAME} "$@"
- [[ ${XORG_EAUTORECONF} != no && ( -e "./configure.ac" || -e "./configure.in" ) ]] && XORG_EAUTORECONF=yes
- [[ ${XORG_EAUTORECONF} != no ]] && eautoreconf
- elibtoolize --patch-only
+ if [[ ${XORG_EAUTORECONF} != no ]] ; then
+ eautoreconf
+ else
+ elibtoolize --patch-only
+ fi
}
# @FUNCTION: xorg-3_src_prepare