summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/descent1-demodata
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/descent1-demodata')
-rw-r--r--games-action/descent1-demodata/Manifest1
-rw-r--r--games-action/descent1-demodata/descent1-demodata-1.4.ebuild61
-rw-r--r--games-action/descent1-demodata/metadata.xml11
3 files changed, 73 insertions, 0 deletions
diff --git a/games-action/descent1-demodata/Manifest b/games-action/descent1-demodata/Manifest
new file mode 100644
index 000000000000..db59b3257a41
--- /dev/null
+++ b/games-action/descent1-demodata/Manifest
@@ -0,0 +1 @@
+DIST desc14sw.exe 2892216 SHA256 3dadb7fbc01efce2904d0908c55d9a9cf1f402e83bf771970552efaca15efcb0 SHA512 121bd909285138eef3009af4a46174a4af241b139230eda5c232fe710b17419e385ffeb97e13678c253390e6393615006c739a8dd4b0e14b375678491629ab3e WHIRLPOOL 5fbc95c6cbb5d26c30c3a5b9cf79b0fe0932d1a1b3886dc4db1e396854592c63e22e7f539b5fef04cb0eefaf902202a1de397d85adab8a7e2466c98127108534
diff --git a/games-action/descent1-demodata/descent1-demodata-1.4.ebuild b/games-action/descent1-demodata/descent1-demodata-1.4.ebuild
new file mode 100644
index 000000000000..2e467ac50862
--- /dev/null
+++ b/games-action/descent1-demodata/descent1-demodata-1.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils unpacker games
+
+MY_PV=${PV/./}
+DEMO="desc${MY_PV}sw.exe"
+
+DESCRIPTION="Demo data files for Descent 1"
+HOMEPAGE="http://en.wikipedia.org/wiki/Descent_%28computer_game%29"
+SRC_URI="http://icculus.org/d2x/data/${DEMO}
+ mirror://3dgamers/descent/${DEMO}
+ ftp://ftp.funet.fi/pub/msdos/games/interplay/${DEMO}"
+
+# See readme.txt
+LICENSE="free-noncomm"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="app-arch/unzip
+ app-arch/unarj"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack_zip ${A}
+
+ unarj e DESCENT1.SOW || die
+ mv descent.pig{,1}
+ unarj e DESCENT2.SOW || die
+ mv descent.pig{,2}
+
+ # From the sows, big porkie pies shall grow
+ cat descent.pig{1,2} > descent.pig || die
+
+ rm *{1,2} *.{bat,exe,EXE,SOW,ubn}
+}
+
+src_install() {
+ local dir=${GAMES_DATADIR}/d1x
+
+ insinto "${dir}"
+ doins descent.*
+
+ dodoc *.txt
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ elog "A client is needed to run the game, e.g. d1x-rebirth."
+ elog "Not all Descent 1 clients support the demo data."
+ echo
+}
diff --git a/games-action/descent1-demodata/metadata.xml b/games-action/descent1-demodata/metadata.xml
new file mode 100644
index 000000000000..821c5f02b7fe
--- /dev/null
+++ b/games-action/descent1-demodata/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+Descent 1 is a classic first-person shooter released in 1995 by Interplay
+and Parallax. It was one of the first games with true 3-dimensional
+graphics, movement, and light sourcing. This is the demo data for the game
+which is used by the various Descent 1 source ports.
+</longdescription>
+</pkgmetadata>