summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/nighthawk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/nighthawk')
-rw-r--r--games-action/nighthawk/Manifest1
-rw-r--r--games-action/nighthawk/files/nighthawk-2.2-gcc42.patch24
-rw-r--r--games-action/nighthawk/files/nighthawk.patch46
-rw-r--r--games-action/nighthawk/metadata.xml5
-rw-r--r--games-action/nighthawk/nighthawk-2.2.ebuild31
5 files changed, 107 insertions, 0 deletions
diff --git a/games-action/nighthawk/Manifest b/games-action/nighthawk/Manifest
new file mode 100644
index 000000000000..6e0aade3d981
--- /dev/null
+++ b/games-action/nighthawk/Manifest
@@ -0,0 +1 @@
+DIST nighthawk-2.2-1.tar.gz 1079706 SHA256 739f154f7c2118879d9d7f5dc0c7d98e1564dc9ae79c864be5e3c04688820bf3 SHA512 dca5d0c01ed651dee0c29b939c832ae343ca70ff0eb7779e7c13007881cf75d96cadafbbac6b431cd473ce9b9e1347dd4ba90502627059439b5a9a557cbc3fcf WHIRLPOOL 2ffeb8de46bb77aa23bec66be4413ffd46c22a793662294316dd5fee2d309d76cc65eb68a4ec06f629dfe9e0accf9eb822c3275b932a3f6432ab5fc6e6dd944f
diff --git a/games-action/nighthawk/files/nighthawk-2.2-gcc42.patch b/games-action/nighthawk/files/nighthawk-2.2-gcc42.patch
new file mode 100644
index 000000000000..619acd37f71f
--- /dev/null
+++ b/games-action/nighthawk/files/nighthawk-2.2-gcc42.patch
@@ -0,0 +1,24 @@
+--- src_sound/dsp_mixxer.c
++++ src_sound/dsp_mixxer.c
+@@ -302,10 +302,8 @@
+ for(sample_no = 0;sample_no < mix_buffer_size;sample_no++)
+ {
+ if(chmix[chan_no].funkctrl & 0x2)
+-#pragma pack(1)
+ sam = *((sDB *)chmix[chan_no].sample_addr +
+ (unsigned long)chmix[chan_no].sample_ptr);
+-#pragma pack()
+ else
+ sam = 0;
+
+@@ -364,10 +362,8 @@
+ for(sample_no = 0;sample_no < mix_buffer_size;sample_no++)
+ {
+ if(chmix[chan_no].funkctrl & 0x2)
+-#pragma pack(1)
+ sam = *((sDW *)chmix[chan_no].sample_addr +
+ (unsigned long)chmix[chan_no].sample_ptr);
+-#pragma pack()
+ else
+ sam = 0;
+ #ifdef DIGITAL_ECHOING
diff --git a/games-action/nighthawk/files/nighthawk.patch b/games-action/nighthawk/files/nighthawk.patch
new file mode 100644
index 000000000000..accef759e682
--- /dev/null
+++ b/games-action/nighthawk/files/nighthawk.patch
@@ -0,0 +1,46 @@
+diff -c -3 -r nighthawk-2.2/src/nighthawk.cc nighthawk.orig/src/nighthawk.cc
+*** nighthawk-2.2/src/nighthawk.cc Sun May 23 01:10:59 1999
+--- nighthawk.orig/src/nighthawk.cc Fri Jul 12 04:18:38 2002
+***************
+*** 20,25 ****
+--- 20,26 ----
+ #include <string.h>
+ #include <signal.h>
+ #include <pwd.h>
++ #include <time.h>
+ #include <sys/types.h>
+ #include <sys/file.h>
+ #include <sys/stat.h>
+diff -c -3 -r nighthawk-2.2/src_sound/Make.common nighthawk.orig/src_sound/Make.common
+*** nighthawk-2.2/src_sound/Make.common Sat May 1 18:04:08 1999
+--- nighthawk.orig/src_sound/Make.common Fri Jul 12 04:23:51 2002
+***************
+*** 10,16 ****
+ endif
+ endif
+
+! HOST_SAFE = 0
+
+ ifeq ($(HOSTTYPE),i386)
+ HOST_SAFE = 1
+--- 10,16 ----
+ endif
+ endif
+
+! HOST_SAFE = 1
+
+ ifeq ($(HOSTTYPE),i386)
+ HOST_SAFE = 1
+*** nighthawk-2.2/src/object.cc Mon Sep 30 21:54:56 2002
+--- nighthawk-orig/src/object.cc Mon Sep 30 21:55:05 2002
+***************
+*** 32,37 ****
+--- 32,39 ----
+ #include "tdroid_8xx.h"
+ #include "tdroid_9xx.h"
+
++ #include <string.h>
++
+ /***************************************************************************
+ *
+ ***************************************************************************/
diff --git a/games-action/nighthawk/metadata.xml b/games-action/nighthawk/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-action/nighthawk/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-action/nighthawk/nighthawk-2.2.ebuild b/games-action/nighthawk/nighthawk-2.2.ebuild
new file mode 100644
index 000000000000..26332989d5e1
--- /dev/null
+++ b/games-action/nighthawk/nighthawk-2.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils games
+
+DESCRIPTION="A tribute to Paradroid by Andrew Braybrook"
+HOMEPAGE="http://night-hawk.sourceforge.net/nighthawk.html"
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/games/arcade/${P}-1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="x11-libs/libXpm"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/nighthawk.patch \
+ "${FILESDIR}"/${P}-gcc42.patch
+ sed -i -e 's:AC_FD_MSG:6:g' configure || die #218936
+ sed -i -e '/LDFLAGS = /d' src/Makefile.in || die
+}
+
+src_install () {
+ default
+ prepgamesdirs
+}