summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-08-07 00:47:08 -0300
committerPacho Ramos <pacho@gentoo.org>2025-01-15 18:29:52 +0100
commitcb33c188cd3641442c8761485d822b4919409298 (patch)
tree3d3c393cd9af8f60d8924f6424cf3aaf7d7ae7c7 /games-arcade
parentnet-wireless/gnome-bluetooth: drop 42.8, 46.0 (diff)
downloadgentoo-cb33c188cd3641442c8761485d822b4919409298.tar.gz
gentoo-cb33c188cd3641442c8761485d822b4919409298.tar.bz2
gentoo-cb33c188cd3641442c8761485d822b4919409298.zip
games-arcade/gnome-nibbles: Bump to 4.1.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/38584 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/gnome-nibbles/Manifest1
-rw-r--r--games-arcade/gnome-nibbles/gnome-nibbles-4.1.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/games-arcade/gnome-nibbles/Manifest b/games-arcade/gnome-nibbles/Manifest
index ba8d3f524772..0a86f6d8fa3c 100644
--- a/games-arcade/gnome-nibbles/Manifest
+++ b/games-arcade/gnome-nibbles/Manifest
@@ -1,2 +1,3 @@
DIST gnome-nibbles-4.0.2.tar.xz 418992 BLAKE2B d94e0c11c683765ff50ec4c72669b6ccdac405a107d1f68675b95ae386ff3ae825e0783ce45f26e974675a243d98a00bb1be224ae29e5f25e3735cf1bbf25990 SHA512 a0f82e4860cc05f9b2fdd2037a59088ef1747e17f660778ba68d6eed328b962e27606dfe2e7a9b0a8f46c68bb5f6ff26f7048fae24ab17fe8d63685656e85025
DIST gnome-nibbles-4.0.4.tar.xz 419784 BLAKE2B 5ddecac8818fe512d84a4d007aa91b2bb747686f3d8471ed4f57b02584755ab0b87f4b479ab445e1197187a7d9a429e6489dd57a9434f7a1a7b7b3d02bee34ba SHA512 751dc492d5facd769e81478e93c55afe7c9a8e64a31e224568d67188cdd07fe568709ee211fe18452e10aa7224d5104284c53b95b52f8721a8e0ec28fe7823cc
+DIST gnome-nibbles-4.1.0.tar.xz 406808 BLAKE2B f50cdcdffdd9847b02f44c50118cb1c3093e30efb8cded142c7c202dffe805867df7544bd8e13289ae6e4599cf6c115f3c0ee634688c8f335c128987f4aa6751 SHA512 bd7cffd267036145997e2845c55420bf687c37713b6f4f97164a5a7d826ae3b7daaa4f610379eaeaa4b13b9cf4cf353156ddf42b3662afc0cf22fbd62b85a510
diff --git a/games-arcade/gnome-nibbles/gnome-nibbles-4.1.0.ebuild b/games-arcade/gnome-nibbles/gnome-nibbles-4.1.0.ebuild
new file mode 100644
index 000000000000..cc3b590f57b8
--- /dev/null
+++ b/games-arcade/gnome-nibbles/gnome-nibbles-4.1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Nibbles clone for GNOME"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-nibbles"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+RDEPEND="
+ >=dev-libs/glib-2.78.0:2
+ dev-libs/libgee:0.8=
+ >=media-libs/gsound-1.0.2
+ >=gui-libs/gtk-4.6:4
+ x11-libs/pango
+ >=dev-libs/libgnome-games-support-2.0.0:2=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+ media-libs/gsound[vala]
+"
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}