summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-10-04 11:59:28 +0200
committerMichał Górny <mgorny@gentoo.org>2015-10-04 12:11:24 +0200
commit8bd3b00dcb0b4e546d6c7cdc43a2122280873c8e (patch)
tree54220d57bcff4d519c8290166f79473999f425a2 /games-emulation/mupen64plus-input-sdl
parentdev-haskell/conduit: amd64 stable wrt bug #550394 (diff)
downloadgentoo-8bd3b00dcb0b4e546d6c7cdc43a2122280873c8e.tar.gz
gentoo-8bd3b00dcb0b4e546d6c7cdc43a2122280873c8e.tar.bz2
gentoo-8bd3b00dcb0b4e546d6c7cdc43a2122280873c8e.zip
games-emulation/mupen64plus*: Version bump to 2.5
Bump mupen64plus to 2.5 which brings a number of bug fixes. Switch to SDL2 as its support become stable and the default. Also switch m64py to SDL2 to match. Package-Manager: portage-2.2.22
Diffstat (limited to 'games-emulation/mupen64plus-input-sdl')
-rw-r--r--games-emulation/mupen64plus-input-sdl/Manifest1
-rw-r--r--games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.5.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/games-emulation/mupen64plus-input-sdl/Manifest b/games-emulation/mupen64plus-input-sdl/Manifest
index f0bddf13ebcf..0b1fc1d15cd1 100644
--- a/games-emulation/mupen64plus-input-sdl/Manifest
+++ b/games-emulation/mupen64plus-input-sdl/Manifest
@@ -1 +1,2 @@
DIST mupen64plus-input-sdl-src-2.0.tar.gz 43553 SHA256 b6be48e978683cced8c208ad03e27828c17ac7b2da5e699d6c34945db63d95b6 SHA512 adbeb83e01721aa74e5e65c05e4bff2a250c7bf51835a8b2c020752e9bf0bdb0f0672914fc5285ad9da2e6fa44259780aea6415d77914bb34e521f30eecf6747 WHIRLPOOL 647ccef13620c863077ae2eefb6934d966eaa413fe70437a38560e5fa03f479428e4848f2c2f3f38163a122a29f8b118fb50f9f772bfd1df96ab2860044352d7
+DIST mupen64plus-input-sdl-src-2.5.tar.gz 50580 SHA256 65e528667b7f57a307b92abba37a3601ee17e9dd9d303ba7e4163b27f3ef771b SHA512 014a5e21feb88b14bcee44a74556a257393b799745308421a611eb3b6c11a390a589fdd393f07e69a128ca60426d4dcf8847bcbabed77b0d570be282550148d6 WHIRLPOOL a3d60880c17939785af93f9a2a9de6d9180ae754580d9a21efd5cfc7b0774b7883115f71dde35b1c448c8fc259e4229866e92c7ac51053055e9878fc90ae48b1
diff --git a/games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.5.ebuild b/games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.5.ebuild
new file mode 100644
index 000000000000..6c4856a28a45
--- /dev/null
+++ b/games-emulation/mupen64plus-input-sdl/mupen64plus-input-sdl-2.5.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P=${PN}-src-${PV}
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, SDL input plugin"
+HOMEPAGE="http://www.mupen64plus.org/"
+SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=games-emulation/mupen64plus-core-2.5:0=
+ media-libs/libsdl2:0=[joystick]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch_user
+
+ # avoid implicitly appending CPU flags
+ sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
+}
+
+src_compile() {
+ MAKEARGS=(
+ # Note: please keep this in sync in all of mupen64plus-* packages
+
+ -C projects/unix
+
+ # this basically means: GNU userspace
+ UNAME=Linux
+
+ # verbose output
+ V=1
+
+ CROSS_COMPILE="${CHOST}-"
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+ # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
+ # so we can leave OPTFLAGS empty
+ OPTFLAGS=
+
+ # paths, some of them are used at compile time
+ PREFIX=/usr
+ LIBDIR=/usr/$(get_libdir)
+
+ # disable unwanted magic
+ LDCONFIG=:
+ INSTALL_STRIP_FLAG=
+
+ # Package-specific stuff
+
+ # CROSS_COMPILE causes it to look for ${CHOST}-sdl2-config...
+ SDL_CFLAGS="$($(tc-getPKG_CONFIG) --cflags sdl2)"
+ SDL_LDLIBS="$($(tc-getPKG_CONFIG) --libs sdl2)"
+ )
+
+ use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
+ use x86 && MAKEARGS+=( HOST_CPU=i386 )
+
+ emake "${MAKEARGS[@]}" all
+}
+
+src_install() {
+ emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+ einstalldocs
+}