summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2024-03-28 21:30:03 -0700
committerJoonas Niilola <juippis@gentoo.org>2024-04-29 11:45:18 +0300
commited4955fb0b70f8fde4eb965a372901bef6d0c689 (patch)
tree4c85ceba2741a21fe464028984efdb7f1edd1af3 /games-emulation/nestopia-jg/nestopia-jg-1.52.1.ebuild
parentnet-libs/libmicrohttpd: upstream version 1.0.1 (diff)
downloadgentoo-ed4955fb0b70f8fde4eb965a372901bef6d0c689.tar.gz
gentoo-ed4955fb0b70f8fde4eb965a372901bef6d0c689.tar.bz2
gentoo-ed4955fb0b70f8fde4eb965a372901bef6d0c689.zip
games-emulation/nestopia-jg: add 1.52.1
Signed-off-by: orbea <orbea@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'games-emulation/nestopia-jg/nestopia-jg-1.52.1.ebuild')
-rw-r--r--games-emulation/nestopia-jg/nestopia-jg-1.52.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-emulation/nestopia-jg/nestopia-jg-1.52.1.ebuild b/games-emulation/nestopia-jg/nestopia-jg-1.52.1.ebuild
new file mode 100644
index 000000000000..0c8527af385d
--- /dev/null
+++ b/games-emulation/nestopia-jg/nestopia-jg-1.52.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Fork of Nestopia"
+HOMEPAGE="https://gitlab.com/jgemu/nestopia"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}