summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViolet Purcell <vimproved@inventati.org>2024-11-15 22:16:06 -0500
committerMaciej Barć <xgqt@gentoo.org>2024-11-17 17:26:47 +0100
commit44676a097bd0fc496b2b14069e9b34a9ec0f1494 (patch)
treef101587215e1bcc5d58d08efc7a62c145c329427 /games-emulation
parentgames-emulation/melonds: update live (diff)
downloadgentoo-44676a097bd0fc496b2b14069e9b34a9ec0f1494.tar.gz
gentoo-44676a097bd0fc496b2b14069e9b34a9ec0f1494.tar.bz2
gentoo-44676a097bd0fc496b2b14069e9b34a9ec0f1494.zip
games-emulation/melonds: add 0.9.5_p20241113
Signed-off-by: Violet Purcell <vimproved@inventati.org> Closes: https://github.com/gentoo/gentoo/pull/39340 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/melonds/Manifest1
-rw-r--r--games-emulation/melonds/melonds-0.9.5_p20241113.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/games-emulation/melonds/Manifest b/games-emulation/melonds/Manifest
index 142ec299889c..74568d66e233 100644
--- a/games-emulation/melonds/Manifest
+++ b/games-emulation/melonds/Manifest
@@ -1 +1,2 @@
DIST melonDS-0.9.5_p20240815.tar.gz 3400066 BLAKE2B c2e530ee12e1ba6cb9d7bc1ac233be984a00a9b182b4f8cab3082dad3b6e0449239455f422113ca8efcbcfafd8a4b8bca3b3dc84c79936e467f001b21b90f79d SHA512 7845be503f272aa2b7e070b19c46893274fc3d44ace3ae1ce11e33da8e58766127cb1c89dcb92bd8084f33a8cc7c0241b7416423ec93fe45858211cd69e1766e
+DIST melonDS-0.9.5_p20241113.tar.gz 3410057 BLAKE2B 6c4e5e8aa1a519a11308d42168c22d6fde8176fe46e96d00edcc34112e16d65aad77d1925b9f1966c198035cccae092902428081f1cf56d40eac30c369477433 SHA512 25b18547899e18e915cfdc0c437472fb39eeac520c478e232783fc5d57430e84b2cd0be1b2bcddfe9f5132877c8278ebb29893e7a104d7731974aa5e44f79914
diff --git a/games-emulation/melonds/melonds-0.9.5_p20241113.ebuild b/games-emulation/melonds/melonds-0.9.5_p20241113.ebuild
new file mode 100644
index 000000000000..3494d438a060
--- /dev/null
+++ b/games-emulation/melonds/melonds-0.9.5_p20241113.ebuild
@@ -0,0 +1,91 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+REAL_PN="melonDS"
+REAL_P="${REAL_PN}-${PV}"
+
+[[ "${PV}" == *p20241113 ]] && COMMIT="5e8beb3ab7277e0fae9a9a1cae8d26a357c570e5"
+
+inherit cmake readme.gentoo-r1 toolchain-funcs xdg
+
+DESCRIPTION="Nintendo DS emulator, sorta"
+HOMEPAGE="http://melonds.kuribo64.net
+ https://github.com/Arisotura/melonDS"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/Arisotura/${REAL_PN}.git"
+else
+ SRC_URI="https://github.com/Arisotura/${REAL_PN}/archive/${COMMIT}.tar.gz
+ -> ${REAL_P}.tar.gz"
+ S="${WORKDIR}/${REAL_PN}-${COMMIT}"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD-2 GPL-2 GPL-3 Unlicense"
+SLOT="0"
+IUSE="+jit +opengl wayland"
+
+RDEPEND="
+ app-arch/libarchive
+ dev-qt/qtbase:6[network,opengl,widgets]
+ dev-qt/qtmultimedia:6
+ dev-qt/qtsvg:6
+ media-libs/libsdl2[sound,video]
+ net-libs/enet:=
+ net-libs/libpcap
+ net-libs/libslirp
+ wayland? (
+ dev-libs/wayland
+ )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ wayland? (
+ kde-frameworks/extra-cmake-modules:0
+ )
+"
+
+# used for JIT recompiler
+QA_EXECSTACK="usr/bin/melonDS"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="You need the following files in order to run melonDS:
+- bios7.bin
+- bios9.bin
+- firmware.bin
+- romlist.bin
+Place them in ~/.config/melonDS
+Those files can be extracted from devices or found somewhere on the Internet ;-)"
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DBUILD_SHARED_LIBS="OFF"
+ -DENABLE_JIT="$(usex jit)"
+ -DENABLE_OGLRENDERER="$(usex opengl)"
+ -DENABLE_WAYLAND="$(usex wayland)"
+ -DUSE_SYSTEM_LIBSLIRP=ON
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ tc-export AR
+ cmake_src_compile
+}
+
+src_install() {
+ readme.gentoo_create_doc
+ cmake_src_install
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ readme.gentoo_print_elog
+}