summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-12-27 17:17:04 -0800
committerSam James <sam@gentoo.org>2023-01-15 14:16:13 +0000
commit80785a22ccda05ce057bf44f7402337b2a85da7b (patch)
treed0beeaad0fe8d6adb190056570316eb1ffdb102c /games-emulation
parentgames-emulation/mednafen-jg: New package, v1.31.0 (diff)
downloadgentoo-80785a22ccda05ce057bf44f7402337b2a85da7b.tar.gz
gentoo-80785a22ccda05ce057bf44f7402337b2a85da7b.tar.bz2
gentoo-80785a22ccda05ce057bf44f7402337b2a85da7b.zip
games-emulation/melonds-jg: New package, v0.9.5
Upstream-PR: https://github.com/melonDS-emu/melonDS/pull/1532 Upstream-Commit: https://github.com/melonDS-emu/melonDS/commit/bd9c614cebe47f809ae125a4bf59649191332a3a Upstream-Commit: https://gitlab.com/jgemu/melonds/-/commit/bd9c614cebe47f809ae125a4bf59649191332a3a Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/melonds-jg/Manifest1
-rw-r--r--games-emulation/melonds-jg/files/melonds-jg-0.9.5-format.patch27
-rw-r--r--games-emulation/melonds-jg/melonds-jg-0.9.5.ebuild53
-rw-r--r--games-emulation/melonds-jg/melonds-jg-9999.ebuild49
-rw-r--r--games-emulation/melonds-jg/metadata.xml21
5 files changed, 151 insertions, 0 deletions
diff --git a/games-emulation/melonds-jg/Manifest b/games-emulation/melonds-jg/Manifest
new file mode 100644
index 000000000000..73472a76c4df
--- /dev/null
+++ b/games-emulation/melonds-jg/Manifest
@@ -0,0 +1 @@
+DIST melonds-0.9.5.tar.bz2 5396317 BLAKE2B 4f834c1037b0a1f2e6acdc52bc0b974107343485cdfeff35d16520afb46895abec3046fa9c91c53b6c02855b19af39a64bfc98722887e5090eb0b051ae0d106b SHA512 11a0a71b20e516f426f6fa6dbb46418c5afdd34997d2943a91149f527ca81c7c9a76db8460439e7593e245df92799a69a76dc426eea14a01383ce0a8c1a4b473
diff --git a/games-emulation/melonds-jg/files/melonds-jg-0.9.5-format.patch b/games-emulation/melonds-jg/files/melonds-jg-0.9.5-format.patch
new file mode 100644
index 000000000000..f107b6b20335
--- /dev/null
+++ b/games-emulation/melonds-jg/files/melonds-jg-0.9.5-format.patch
@@ -0,0 +1,27 @@
+Upstream-PR: https://github.com/melonDS-emu/melonDS/pull/1532
+Upstream-Commit: https://github.com/melonDS-emu/melonDS/commit/bd9c614cebe47f809ae125a4bf59649191332a3a
+melonds-jg-Commit: https://gitlab.com/jgemu/melonds/-/commit/bd9c614cebe47f809ae125a4bf59649191332a3a
+
+From bd9c614cebe47f809ae125a4bf59649191332a3a Mon Sep 17 00:00:00 2001
+From: Rupert Carmichael <54966017+carmiker@users.noreply.github.com>
+Date: Fri, 30 Dec 2022 15:13:39 -0500
+Subject: [PATCH] Wifi: -Wformat warning caused by missing printf argument
+ (#1532)
+
+---
+ src/Wifi.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Wifi.cpp b/src/Wifi.cpp
+index c2614e7..5373187 100644
+--- a/src/Wifi.cpp
++++ b/src/Wifi.cpp
+@@ -872,7 +872,7 @@ bool ProcessTX(TXSlot* slot, int num)
+ }
+
+ if ((num != 5) && (RAM[slot->Addr+4] > 0))
+- printf("SLOT %d RETRY COUNTER %d\n", RAM[slot->Addr+4]);
++ printf("SLOT %d RETRY COUNTER %d\n", num, RAM[slot->Addr+4]);
+
+ // set TX addr
+ IOPORT(W_RXTXAddr) = slot->Addr >> 1;
diff --git a/games-emulation/melonds-jg/melonds-jg-0.9.5.ebuild b/games-emulation/melonds-jg/melonds-jg-0.9.5.ebuild
new file mode 100644
index 000000000000..72f8d74e4dd2
--- /dev/null
+++ b/games-emulation/melonds-jg/melonds-jg-0.9.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Port of melonDS"
+HOMEPAGE="https://gitlab.com/jgemu/melonds"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD-1 BSD-2 GPL-3+ MIT Unlicense public-domain"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+ media-libs/libsamplerate
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-format.patch
+)
+
+src_compile() {
+ emake -C jollygood \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake -C jollygood install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
diff --git a/games-emulation/melonds-jg/melonds-jg-9999.ebuild b/games-emulation/melonds-jg/melonds-jg-9999.ebuild
new file mode 100644
index 000000000000..44ef9ee4e7eb
--- /dev/null
+++ b/games-emulation/melonds-jg/melonds-jg-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Port of melonDS"
+HOMEPAGE="https://gitlab.com/jgemu/melonds"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD-1 BSD-2 GPL-3+ MIT Unlicense public-domain"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+ media-libs/libsamplerate
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake -C jollygood \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake -C jollygood install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
diff --git a/games-emulation/melonds-jg/metadata.xml b/games-emulation/melonds-jg/metadata.xml
new file mode 100644
index 000000000000..010aa0b949dc
--- /dev/null
+++ b/games-emulation/melonds-jg/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>orbea@riseup.net</email>
+ <name>orbea</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ melonDS is an emulator for the Nintendo DS and DSi. The
+ Jolly Good API port is designed for use with content for
+ the Nintendo DS.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://gitlab.com/jgemu/melonds/-/issues</bugs-to>
+ <remote-id type="gitlab">jgemu/melonds</remote-id>
+ </upstream>
+</pkgmetadata>