summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-misc/c++robots
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-misc/c++robots')
-rw-r--r--games-misc/c++robots/Manifest1
-rw-r--r--games-misc/c++robots/c++robots-0.ebuild33
-rw-r--r--games-misc/c++robots/files/proper-coding.patch51
-rw-r--r--games-misc/c++robots/metadata.xml5
4 files changed, 90 insertions, 0 deletions
diff --git a/games-misc/c++robots/Manifest b/games-misc/c++robots/Manifest
new file mode 100644
index 000000000000..30d5dd3e9613
--- /dev/null
+++ b/games-misc/c++robots/Manifest
@@ -0,0 +1 @@
+DIST c++robots.tar.gz 10896 SHA256 8102fb0da308e6118676d54642cd6f652fcfa145384a7e830ca7103aaf02f3f5 SHA512 410a08c920f8e54abe74b085d67607bcc381e768c0127cf98eabab894a106d5d1466a1cac4146924b53c29ccffddd5eb77c9383c42b6fe6e48c7e89691e691f3 WHIRLPOOL 24483a323e2c7bbdc3e116635f1433ffd133e9886631373b7a660456078dde33a46c9479757cbc02d66c9aaa98811946eea5b791625fd0a340bd33ad9bdd8d04
diff --git a/games-misc/c++robots/c++robots-0.ebuild b/games-misc/c++robots/c++robots-0.ebuild
new file mode 100644
index 000000000000..a243b7276085
--- /dev/null
+++ b/games-misc/c++robots/c++robots-0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils games
+
+DESCRIPTION="ongoing 'King of the Hill' (KotH) tournament"
+HOMEPAGE="http://www.gamerz.net/c++robots/"
+SRC_URI="http://www.gamerz.net/c++robots/c++robots.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86 ppc"
+IUSE="static"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}/proper-coding.patch"
+}
+
+src_compile() {
+ local myldflags="${LDFLAGS}"
+ use static && myldflags="${myldflags} -static"
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${myldflags}"
+}
+
+src_install() {
+ dogamesbin combat cylon target tracker
+ dodoc README
+ prepgamesdirs
+}
diff --git a/games-misc/c++robots/files/proper-coding.patch b/games-misc/c++robots/files/proper-coding.patch
new file mode 100644
index 000000000000..f54af0389079
--- /dev/null
+++ b/games-misc/c++robots/files/proper-coding.patch
@@ -0,0 +1,51 @@
+--- Makefile.orig 2003-01-01 23:36:19.000000000 -0500
++++ Makefile 2003-01-01 23:39:32.000000000 -0500
+@@ -1,8 +1,9 @@
+ CFLAGS=-g
++LDFLAGS=
+ PROGRAMS=combat
+ ROBOTS=cylon tracker target
+
+-CC=g++ -g
++CC=g++
+
+ all: $(PROGRAMS) $(ROBOTS)
+
+@@ -10,29 +11,29 @@
+ rm -f $(PROGRAMS) $(ROBOTS) *.o core
+
+ combat: combat.o
+- $(CC) $(CFLAGS) -o $@ combat.o -lm
++ $(CC) -o $@ $(LDFLAGS) combat.o -lm
+
+ combat.o: combat.c
+ $(CC) $(CFLAGS) -c combat.c
+
+ robots.o: robots.C robots.h
+- g++ -c robots.C
++ $(CC) $(CFLAGS) -c robots.C
+
+ cylon: cylon.o robots.o
+- g++ -static -o $@ cylon.o robots.o
++ $(CC) -o $@ $(LDFLAGS) cylon.o robots.o
+
+ cylon.o: cylon.c robots.h
+- g++ -c cylon.c
++ $(CC) $(CFLAGS) -c cylon.c
+
+ tracker: tracker.o robots.o
+- g++ -static -o $@ tracker.o robots.o
++ $(CC) -o $@ $(LDFLAGS) tracker.o robots.o
+
+ tracker.o: tracker.c robots.h
+- g++ -c tracker.c
++ $(CC) $(CFLAGS) -c tracker.c
+
+ target: target.o robots.o
+- g++ -static -o $@ target.o robots.o
++ $(CC) -o $@ $(LDFLAGS) target.o robots.o
+
+ target.o: target.c robots.h
+- g++ -c target.c
++ $(CC) $(CFLAGS) -c target.c
+
diff --git a/games-misc/c++robots/metadata.xml b/games-misc/c++robots/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-misc/c++robots/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>