summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/seatris
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/seatris')
-rw-r--r--games-puzzle/seatris/Manifest1
-rw-r--r--games-puzzle/seatris/files/seatris-0.0.14-as-needed.patch11
-rw-r--r--games-puzzle/seatris/metadata.xml5
-rw-r--r--games-puzzle/seatris/seatris-0.0.14.ebuild40
4 files changed, 57 insertions, 0 deletions
diff --git a/games-puzzle/seatris/Manifest b/games-puzzle/seatris/Manifest
new file mode 100644
index 000000000000..dba165add7a2
--- /dev/null
+++ b/games-puzzle/seatris/Manifest
@@ -0,0 +1 @@
+DIST seatris-0.0.14.tar.gz 53056 SHA256 797ec1403dec2e6c790ec77d41bc5201055cfbef4d9ad7054270845c909d0a2e SHA512 105722ddbeaa8ae3863331126cf816e7d590ebe4ca244b32d3275071c2537c2865183a90f60f8dbf46cfacbcee4e811b653ff9cc6d2eae51c9ed6efa9263fac2 WHIRLPOOL 97a509c9a2c5cc6595e647029a69ad59bf20df255a958ce777a3598dcaeb7055a98cf8b2897d08ac0230bb71ff80684d45bcb9367c67699fd66157f809f28964
diff --git a/games-puzzle/seatris/files/seatris-0.0.14-as-needed.patch b/games-puzzle/seatris/files/seatris-0.0.14-as-needed.patch
new file mode 100644
index 000000000000..e77c0dd75077
--- /dev/null
+++ b/games-puzzle/seatris/files/seatris-0.0.14-as-needed.patch
@@ -0,0 +1,11 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -11,7 +11,7 @@
+ parse.o readcfg.o
+
+ seatris: $(OBJS)
+- $(CC) $(LFLAGS) $(LIBS) -o seatris $(OBJS)
++ $(CC) $(LDFLAGS) -o seatris $(OBJS) $(LIBS)
+
+ clean:
+ rm -f *.o seatris
diff --git a/games-puzzle/seatris/metadata.xml b/games-puzzle/seatris/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/seatris/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-puzzle/seatris/seatris-0.0.14.ebuild b/games-puzzle/seatris/seatris-0.0.14.ebuild
new file mode 100644
index 000000000000..c5888ad3a69f
--- /dev/null
+++ b/games-puzzle/seatris/seatris-0.0.14.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs games
+
+DESCRIPTION="A color ncurses tetris clone"
+HOMEPAGE="http://www.earth.li/projectpurple/progs/seatris.html"
+SRC_URI="http://www.earth.li/projectpurple/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ppc64 x86"
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i \
+ -e "s:/var/lib/games:${GAMES_STATEDIR}:" \
+ scoring.h seatris.6 || die
+
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+}
+
+src_compile() {
+ emake LIBS="$( $(tc-getPKG_CONFIG) --libs ncurses )"
+}
+
+src_install () {
+ dogamesbin seatris
+ doman seatris.6
+ dodoc ACKNOWLEDGEMENTS HISTORY README TODO example.seatrisrc
+ dodir "${GAMES_STATEDIR}"
+ touch "${D}${GAMES_STATEDIR}/seatris.score"
+ fperms 660 "${GAMES_STATEDIR}/seatris.score"
+ prepgamesdirs
+}