summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-10-15 05:24:36 -0500
committerAustin English <wizardedit@gentoo.org>2016-10-15 06:08:15 -0500
commit8e0b4113b8d8532fadfeb203da7ccddf663ea3aa (patch)
treeaf10e87ade61a18abdbd1fa8fb0b535616f6dd5b /games-rpg
parentprofiles: Mask USE=cairo for app-editors/emacs{,-vcs}. (diff)
downloadgentoo-8e0b4113b8d8532fadfeb203da7ccddf663ea3aa.tar.gz
gentoo-8e0b4113b8d8532fadfeb203da7ccddf663ea3aa.tar.bz2
gentoo-8e0b4113b8d8532fadfeb203da7ccddf663ea3aa.zip
games-rpg/kqlives: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/kqlives/kqlives-0.99-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-rpg/kqlives/kqlives-0.99-r1.ebuild b/games-rpg/kqlives/kqlives-0.99-r1.ebuild
new file mode 100644
index 000000000000..21db6f61423d
--- /dev/null
+++ b/games-rpg/kqlives/kqlives-0.99-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+MY_P=${P/lives}
+
+DESCRIPTION="A console-style role playing game"
+HOMEPAGE="http://kqlives.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cheats nls"
+
+RDEPEND="
+ dev-lang/lua:0
+ >=gnome-base/libglade-2.4
+ media-libs/aldumb
+ media-libs/allegro:0
+ >=x11-libs/gtk+-2.8:2
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ econf \
+ $(use_enable cheats) \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+
+ local x
+ for x in diff draw draw2 dump; do
+ mv -vf "${D}/etc"/map${x} "${D}/etc"/kq-map${x}
+ done
+
+ doicon "${FILESDIR}"/${PN}.xpm
+ make_desktop_entry kq KqLives ${PN}
+}