summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2025-01-16 18:32:32 +0300
committerJames Le Cuirot <chewi@gentoo.org>2025-01-16 23:06:17 +0000
commite6ac94648f52339587dd771f49f9cfd9ca3c785a (patch)
treeaac22b963aa62353d55afea9874da5d5ec7e80a5 /games-rpg
parentmedia-libs/faun: drop 0.1.4 (diff)
downloadgentoo-e6ac94648f52339587dd771f49f9cfd9ca3c785a.tar.gz
gentoo-e6ac94648f52339587dd771f49f9cfd9ca3c785a.tar.bz2
gentoo-e6ac94648f52339587dd771f49f9cfd9ca3c785a.zip
games-rpg/xu4: add 1.4.2
Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/xu4/Manifest1
-rw-r--r--games-rpg/xu4/xu4-1.4.2.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/games-rpg/xu4/Manifest b/games-rpg/xu4/Manifest
index 41735b7c63e1..1b138051904f 100644
--- a/games-rpg/xu4/Manifest
+++ b/games-rpg/xu4/Manifest
@@ -1,3 +1,4 @@
DIST u4upgrad.zip 632072 BLAKE2B 3691f1cbac940021ef6043dd5e2ee26dcee5f8d7181ed525179211a6984f5ab498b84533d28146129c3e747f0af8946f7d691b7cb817a5a4ecb39e71e2df7b9a SHA512 4832d8cfd266d3ccc5eab5184bd2b6b9acd4c0203478873fb5e11704d95104dd9285a7752bad77f873d4f8603673184ae9421964509b948ec69944a4ceadd083
DIST ultima4.zip 529099 BLAKE2B 62a7e6e05344d0c3496ee3240d6cd98c61f1ff8b8f5d869a8cecec8f786b76c8a42e1bef40fa63861d5652352c00ba67708e49b5e6c9ddfdebbb3ae47ae01e2e SHA512 efc65a53492c0f68c9e2f1507afed4da925992cdfec7a699095e6369725af8156331000c575778121e04ef6ca252af2eef97f8f7183b8378f22a4e7e509fb9a5
+DIST xu4-1.4.2.gh.tar.gz 8069084 BLAKE2B 6150427c202597b730bfc1c44b0e92d60c90997804fc66b2d108247b7a8578f26ca5fb49acf8afd438437d544141871ff5dc437f00edc74473a500065a21aa43 SHA512 d2ae3fdf47809d4238f986594f182326538d2bbfcd0bacade859a70b8ad91d7b387a3f3d4561361cc3cbd715cc4d54c73c01ad61dcdf10948e715e714e5147f0
DIST xu4-1.4.gh.tar.gz 8053080 BLAKE2B 3d098c426bce5b9e6c7665007388be9f189d2fc780b575fa586418e77196027f23092201bc566d41b1d9725180b85f1a7fcbb811a274c19f94d907adb6df4f43 SHA512 2061db91727fe372007c7a79c9f23f9bc78fcc6e1359e2e14ed2e7277e745e3e2a9a8fd7a16e7b42f8bd85ca692115ef22ba95122f8fbfe67c72c2cbed39c95b
diff --git a/games-rpg/xu4/xu4-1.4.2.ebuild b/games-rpg/xu4/xu4-1.4.2.ebuild
new file mode 100644
index 000000000000..740be0fe0cdb
--- /dev/null
+++ b/games-rpg/xu4/xu4-1.4.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A remake of the computer game Ultima IV"
+HOMEPAGE="https://xu4.sourceforge.net/"
+SRC_URI="https://github.com/xu4-engine/u4/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz
+ https://ultima.thatfleminggent.com/ultima4.zip
+ https://downloads.sourceforge.net/xu4/u4upgrad.zip"
+S="${WORKDIR}/u4-${PV}/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/boron
+ media-libs/allegro:5[opengl]
+ >=media-libs/faun-0.2.1
+ media-libs/libglvnd
+ media-libs/libpng:=
+ sys-libs/zlib:=[minizip]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/unzip"
+
+PATCHES=(
+ "${FILESDIR}/1.4-system-minizip.patch"
+)
+
+src_unpack() {
+ # xu4 will read the data files right out of the zip files
+ # but we want the docs from the original.
+ unpack ${P}.gh.tar.gz
+ unpack ultima4.zip
+ # Place zips where make install expects them
+ cp "${DISTDIR}/ultima4.zip" "${DISTDIR}/u4upgrad.zip" "${S}" || die
+}
+
+src_prepare() {
+ default
+
+ # rm as part of using system minizip patch
+ rm -f src/unzip.{c,h} || die
+ sed -i -e '/CXXFLAGS+=-O3 -DNDEBUG/d' src/Makefile || die
+ # Don't strip executable
+ sed -i -e 's:-s src/xu4:src/xu4:g' Makefile || die
+}
+
+src_configure() {
+ # custom configure
+ ./configure --allegro || die
+}
+
+src_install() {
+ emake DESTDIR="${D}/usr" install
+ dodoc AUTHORS README.md doc/*.txt "${WORKDIR}"/*.txt
+ insinto "/usr/share/xu4"
+ doins "${DISTDIR}/ultima4.zip"
+}