summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOursDesCavernes <totocoq@yahoo.fr>2018-03-23 00:14:51 +0100
committerMichał Górny <mgorny@gentoo.org>2018-05-12 19:41:34 +0200
commit9e6f93c2c3cf0761eac9a4259a96e086e21e86ba (patch)
tree4d3ff4301f56c6ce0e7b8b620d83c538f0fe34dd /games-util/springlobby
parentnet-dns/pdns: Version bump, security bug #655318 (diff)
downloadgentoo-9e6f93c2c3cf0761eac9a4259a96e086e21e86ba.tar.gz
gentoo-9e6f93c2c3cf0761eac9a4259a96e086e21e86ba.tar.bz2
gentoo-9e6f93c2c3cf0761eac9a4259a96e086e21e86ba.zip
games-util/springlobby: new package
Closes: https://github.com/gentoo/gentoo/pull/7558
Diffstat (limited to 'games-util/springlobby')
-rw-r--r--games-util/springlobby/Manifest1
-rw-r--r--games-util/springlobby/metadata.xml26
-rw-r--r--games-util/springlobby/springlobby-0.264.ebuild54
3 files changed, 81 insertions, 0 deletions
diff --git a/games-util/springlobby/Manifest b/games-util/springlobby/Manifest
new file mode 100644
index 000000000000..40c8d80469e1
--- /dev/null
+++ b/games-util/springlobby/Manifest
@@ -0,0 +1 @@
+DIST springlobby-0.264.tar.bz2 2626180 BLAKE2B 01ff51703c3c10c1aaeb342d2644012a6037b1271ba7e36ab7663cde7646d1c9c6bd823fe65c91a8a9e754bbcf1000ce486eeab2d1641c64fad08773c491f9a6 SHA512 f8024a98be7d6ea755c4380494415813084aadb6dcf72ed0aaeba0ddf9fbaf992ccd5455713c807c0d6feb7db606068be62d4bb2cfcb4697f0406a2ec4f404eb
diff --git a/games-util/springlobby/metadata.xml b/games-util/springlobby/metadata.xml
new file mode 100644
index 000000000000..eabc7ba13bca
--- /dev/null
+++ b/games-util/springlobby/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+The official lobby client for SpringRTS community games: Balanced Annihilation; Journeywar; Metal Factions; Spring:1944 World War II; Star Wars: Imperial Winter; Tech Annihilation; The Cursed; Evolution RTS; ...
+ </longdescription>
+ <longdescription lang="fr">
+Le client officiel du lobby pour les jeux de la communauté SpringRTS : Balanced Annihilation; Journeywar; Metal Factions; Spring:1944 World War II; Star Wars: Imperial Winter; Tech Annihilation; The Cursed; Evolution RTS; ...
+ </longdescription>
+ <maintainer type="person">
+ <email>totocoq@yahoo.fr</email>
+ <name>Thomas Coquelin</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>fedja@protonmail.ch</email>
+ <name>Fedja Beader</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">springlobby/springlobby</remote-id>
+ <bugs-to>https://github.com/springlobby/springlobby/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/games-util/springlobby/springlobby-0.264.ebuild b/games-util/springlobby/springlobby-0.264.ebuild
new file mode 100644
index 000000000000..510738cb07bd
--- /dev/null
+++ b/games-util/springlobby/springlobby-0.264.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WX_GTK_VER="3.0"
+inherit cmake-utils gnome2-utils wxwidgets
+
+DESCRIPTION="The official lobby client for SpringRTS community games"
+HOMEPAGE="https://springlobby.info"
+SRC_URI="https://www.springlobby.info/tarballs/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +libnotify +nls +sound"
+
+RDEPEND="
+ >=dev-libs/boost-1.35:=
+ dev-libs/openssl:=
+ sound? ( media-libs/alure
+ media-libs/openal
+ )
+ net-misc/curl
+ sys-libs/zlib[minizip]
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXext
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+ libnotify? ( x11-libs/libnotify )
+"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ setup-wxwidgets
+ local mycmakeargs=(
+ -DOPTION_NOTIFY=$(usex libnotify)
+ -DOPTION_SOUND=$(usex sound)
+ -DOPTION_TRANSLATION_SUPPORT=$(usex nls)
+ -DAUX_VERSION="(Gentoo,${ARCH})"
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}