summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-base/gnome-core-apps
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-base/gnome-core-apps')
-rw-r--r--gnome-base/gnome-core-apps/gnome-core-apps-3.14.0.ebuild55
-rw-r--r--gnome-base/gnome-core-apps/gnome-core-apps-3.16.0.ebuild55
-rw-r--r--gnome-base/gnome-core-apps/metadata.xml5
3 files changed, 115 insertions, 0 deletions
diff --git a/gnome-base/gnome-core-apps/gnome-core-apps-3.14.0.ebuild b/gnome-base/gnome-core-apps/gnome-core-apps-3.14.0.ebuild
new file mode 100644
index 000000000000..7c66e1d88991
--- /dev/null
+++ b/gnome-base/gnome-core-apps/gnome-core-apps-3.14.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="Sub-meta package for the core applications integrated with GNOME 3"
+HOMEPAGE="http://www.gnome.org/"
+LICENSE="metapackage"
+SLOT="3.0"
+IUSE="+bluetooth +cdr cups"
+
+# when unmasking for an arch
+# double check none of the deps are still masked !
+KEYWORDS="amd64 ~arm ~ia64 ~ppc ~ppc64 x86"
+
+# Note to developers:
+# This is a wrapper for the core apps tightly integrated with GNOME 3
+# gtk-engines:2 is still around because it's needed for gtk2 apps
+RDEPEND="
+ >=gnome-base/gnome-core-libs-${PV}[cups?]
+
+ >=gnome-base/gnome-session-${PV}
+ >=gnome-base/gnome-menus-3.10.1:3
+ >=gnome-base/gnome-settings-daemon-${PV}[cups?]
+ >=gnome-base/gnome-control-center-${PV}[cups?]
+
+ >=app-crypt/gcr-${PV}
+ >=gnome-base/nautilus-${PV}
+ >=gnome-base/gnome-keyring-${PV}
+ >=gnome-extra/evolution-data-server-3.12.9
+
+ >=app-crypt/seahorse-${PV}
+ >=app-editors/gedit-${PV}
+ >=app-text/evince-${PV}
+ >=gnome-extra/gnome-contacts-${PV}
+ >=media-gfx/eog-${PV}
+ >=media-video/totem-${PV}
+ >=net-im/empathy-3.12.7
+ >=x11-terms/gnome-terminal-${PV}
+
+ >=gnome-extra/gnome-user-docs-${PV}
+ >=gnome-extra/yelp-${PV}
+
+ >=x11-themes/adwaita-icon-theme-${PV}
+ >=x11-themes/gnome-themes-standard-${PV}
+
+ bluetooth? ( >=net-wireless/gnome-bluetooth-${PV} )
+ cdr? ( >=app-cdr/brasero-3.12.0 )
+
+ !gnome-base/gnome-applets
+"
+DEPEND=""
+
+S="${WORKDIR}"
diff --git a/gnome-base/gnome-core-apps/gnome-core-apps-3.16.0.ebuild b/gnome-base/gnome-core-apps/gnome-core-apps-3.16.0.ebuild
new file mode 100644
index 000000000000..b32d6cf7fa68
--- /dev/null
+++ b/gnome-base/gnome-core-apps/gnome-core-apps-3.16.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="Sub-meta package for the core applications integrated with GNOME 3"
+HOMEPAGE="http://www.gnome.org/"
+LICENSE="metapackage"
+SLOT="3.0"
+IUSE="+bluetooth +cdr cups"
+
+# when unmasking for an arch
+# double check none of the deps are still masked !
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
+
+# Note to developers:
+# This is a wrapper for the core apps tightly integrated with GNOME 3
+# gtk-engines:2 is still around because it's needed for gtk2 apps
+RDEPEND="
+ >=gnome-base/gnome-core-libs-${PV}[cups?]
+
+ >=gnome-base/gnome-session-${PV}
+ >=gnome-base/gnome-menus-3.10.1:3
+ >=gnome-base/gnome-settings-daemon-${PV}[cups?]
+ >=gnome-base/gnome-control-center-${PV}[cups?]
+
+ >=app-crypt/gcr-${PV}
+ >=gnome-base/nautilus-${PV}
+ >=gnome-base/gnome-keyring-${PV}
+ >=gnome-extra/evolution-data-server-3.16
+
+ >=app-crypt/seahorse-${PV}
+ >=app-editors/gedit-${PV}
+ >=app-text/evince-${PV}
+ >=gnome-extra/gnome-contacts-${PV}
+ >=media-gfx/eog-${PV}
+ >=media-video/totem-${PV}
+ >=net-im/empathy-3.12.10
+ >=x11-terms/gnome-terminal-${PV}
+
+ >=gnome-extra/gnome-user-docs-${PV}
+ >=gnome-extra/yelp-${PV}
+
+ >=x11-themes/adwaita-icon-theme-${PV}
+ >=x11-themes/gnome-themes-standard-${PV}
+
+ bluetooth? ( >=net-wireless/gnome-bluetooth-${PV} )
+ cdr? ( >=app-cdr/brasero-3.12.1 )
+
+ !gnome-base/gnome-applets
+"
+DEPEND=""
+
+S="${WORKDIR}"
diff --git a/gnome-base/gnome-core-apps/metadata.xml b/gnome-base/gnome-core-apps/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/gnome-base/gnome-core-apps/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>