summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-04-08 11:03:29 -0700
committerMatt Turner <mattst88@gentoo.org>2022-04-08 11:04:20 -0700
commite1b75bb5ecb953f5501cce82dabe07994aff338f (patch)
tree27ac73802ba83649b8316d40facc2bd4e8fc0c09 /gnome-base
parentnet-misc/yt-dlp: also drop certifi from requirements.txt (diff)
downloadgentoo-e1b75bb5ecb953f5501cce82dabe07994aff338f.tar.gz
gentoo-e1b75bb5ecb953f5501cce82dabe07994aff338f.tar.bz2
gentoo-e1b75bb5ecb953f5501cce82dabe07994aff338f.zip
gnome-base/gnome-control-center: Add patch to fix goa-helper on X11
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-control-center/files/42.0-online-accounts-Fix-goa-helper-on-X11.patch32
-rw-r--r--gnome-base/gnome-control-center/gnome-control-center-42.0-r1.ebuild (renamed from gnome-base/gnome-control-center/gnome-control-center-42.0.ebuild)2
2 files changed, 34 insertions, 0 deletions
diff --git a/gnome-base/gnome-control-center/files/42.0-online-accounts-Fix-goa-helper-on-X11.patch b/gnome-base/gnome-control-center/files/42.0-online-accounts-Fix-goa-helper-on-X11.patch
new file mode 100644
index 000000000000..dfa56eab9e61
--- /dev/null
+++ b/gnome-base/gnome-control-center/files/42.0-online-accounts-Fix-goa-helper-on-X11.patch
@@ -0,0 +1,32 @@
+From 7fe322b9cedae313cd9af6f403eab9bfc6027674 Mon Sep 17 00:00:00 2001
+From: Jan Tojnar <jtojnar@gmail.com>
+Date: Mon, 28 Mar 2022 21:02:23 +0200
+Subject: [PATCH] online-accounts: Fix goa-helper on X11
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+The handle_str contains the “x11:” prefix so strtol would return 0.
+We need to pass it the numeric substring.
+
+Fixes: https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues/1651
+---
+ panels/online-accounts/gnome-control-center-goa-helper.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/panels/online-accounts/gnome-control-center-goa-helper.c b/panels/online-accounts/gnome-control-center-goa-helper.c
+index 56513147e..533609cbc 100644
+--- a/panels/online-accounts/gnome-control-center-goa-helper.c
++++ b/panels/online-accounts/gnome-control-center-goa-helper.c
+@@ -129,7 +129,7 @@ set_external_parent_from_handle (GtkApplication *application,
+ int xid;
+
+ errno = 0;
+- xid = strtol (handle_str, NULL, 16);
++ xid = strtol (handle_str + strlen (x11_prefix), NULL, 16);
+ if (errno != 0)
+ {
+ g_warning ("Failed to reference external X11 window, invalid XID %s", handle_str);
+--
+2.35.1
+
diff --git a/gnome-base/gnome-control-center/gnome-control-center-42.0.ebuild b/gnome-base/gnome-control-center/gnome-control-center-42.0-r1.ebuild
index 43a08b3e178c..70008f3ef6ff 100644
--- a/gnome-base/gnome-control-center/gnome-control-center-42.0.ebuild
+++ b/gnome-base/gnome-control-center/gnome-control-center-42.0-r1.ebuild
@@ -118,6 +118,8 @@ BDEPEND="
"
PATCHES=(
+ "${FILESDIR}"/${PV}-online-accounts-Fix-goa-helper-on-X11.patch
+
# Patches from gnome-40 branch on top of 40.0
# Makes some panels and dependencies optional
# https://bugzilla.gnome.org/686840, 697478, 700145