summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/cinnamon-settings-daemon/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/cinnamon-settings-daemon/files')
-rw-r--r--gnome-extra/cinnamon-settings-daemon/files/cinnamon-settings-daemon-2.4.3-optional.patch82
-rw-r--r--gnome-extra/cinnamon-settings-daemon/files/cinnamon-settings-daemon-2.6.2-optional.patch99
2 files changed, 181 insertions, 0 deletions
diff --git a/gnome-extra/cinnamon-settings-daemon/files/cinnamon-settings-daemon-2.4.3-optional.patch b/gnome-extra/cinnamon-settings-daemon/files/cinnamon-settings-daemon-2.4.3-optional.patch
new file mode 100644
index 000000000000..894642781e67
--- /dev/null
+++ b/gnome-extra/cinnamon-settings-daemon/files/cinnamon-settings-daemon-2.4.3-optional.patch
@@ -0,0 +1,82 @@
+From 0bfad0d65540acc6598c694904cdb9f7032c952d Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Mon, 5 May 2014 21:50:25 -0400
+Subject: [PATCH] Make colord and wacom support optional and non-automagic
+
+---
+ configure.ac | 20 +++++++++++++++++---
+ plugins/Makefile.am | 7 ++++++-
+ 2 files changed, 23 insertions(+), 4 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 6a17530..e5a752c 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -260,15 +260,28 @@ fi
+ dnl ---------------------------------------------------------------------------
+ dnl - color
+ dnl ---------------------------------------------------------------------------
++AC_ARG_ENABLE(color,
++ AS_HELP_STRING([--disable-color], [disable Colord support (default: enabled)]),,
++ enable_color=yes)
++build_color=false
++if test x"$enable_color" != x"no" ; then
++ PKG_CHECK_MODULES(COLOR, [colord >= 0.1.9 cinnamon-desktop >= $CINNAMON_DESKTOP_REQUIRED_VERSION libcanberra-gtk3])
++ build_color=true
++fi
+
+-PKG_CHECK_MODULES(COLOR, [colord >= 0.1.9 cinnamon-desktop >= $CINNAMON_DESKTOP_REQUIRED_VERSION libcanberra-gtk3])
++AM_CONDITIONAL(BUILD_COLOR, [test "x$build_color" = "xtrue"])
+
+ dnl ---------------------------------------------------------------------------
+ dnl - wacom
+ dnl ---------------------------------------------------------------------------
++AC_ARG_ENABLE(wacom,
++ AS_HELP_STRING([--disable-wacom], [disable Wacom support (default: auto)]),,
++ enable_wacom=auto)
+ build_wacom=false
+-PKG_CHECK_MODULES(WACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION x11 xi xtst gudev-1.0 cinnamon-desktop xorg-wacom librsvg-2.0 >= $LIBRSVG_REQUIRED_VERSION gtk+-3.0 >= 3.8.0],
+- [build_wacom="true" AC_DEFINE(HAVE_WACOM, 1, [Define if wacom is being build])], [build_wacom="false"])
++if test x"$enable_wacom" != x"no" ; then
++ PKG_CHECK_MODULES(WACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION x11 xi xtst gudev-1.0 cinnamon-desktop xorg-wacom librsvg-2.0 >= $LIBRSVG_REQUIRED_VERSION gtk+-3.0 >= 3.8.0],
++ [build_wacom="true" AC_DEFINE(HAVE_WACOM, 1, [Define if wacom is being build])], [build_wacom="false"])
++fi
+
+ AM_CONDITIONAL(BUILD_WACOM, test "x$build_wacom" = "xtrue")
+
+@@ -604,6 +617,7 @@ echo "
+ LCMS DICT support: ${have_new_lcms}
+ Libnotify support: ${have_libnotify}
+
++ Colord support: ${build_color}
+ Wacom support: ${build_wacom}
+
+ Smartcard support: ${have_smartcard_support}
+diff --git a/plugins/Makefile.am b/plugins/Makefile.am
+index b9cb3a6..f37eec0 100644
+--- a/plugins/Makefile.am
++++ b/plugins/Makefile.am
+@@ -6,7 +6,6 @@ enabled_plugins = \
+ automount \
+ background \
+ clipboard \
+- color \
+ cursor \
+ dummy \
+ datetime \
+@@ -23,6 +22,12 @@ enabled_plugins = \
+
+ disabled_plugins = $(NULL)
+
++if BUILD_COLOR
++enabled_plugins += color
++else
++disabled_plugins += color
++endif
++
+ if BUILD_WACOM
+ enabled_plugins += wacom
+ else
+--
+2.2.1
+
diff --git a/gnome-extra/cinnamon-settings-daemon/files/cinnamon-settings-daemon-2.6.2-optional.patch b/gnome-extra/cinnamon-settings-daemon/files/cinnamon-settings-daemon-2.6.2-optional.patch
new file mode 100644
index 000000000000..e5abe075f5e9
--- /dev/null
+++ b/gnome-extra/cinnamon-settings-daemon/files/cinnamon-settings-daemon-2.6.2-optional.patch
@@ -0,0 +1,99 @@
+From 884ce49f5bcdca37a30fef94d6649af012c88fee Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Sat, 13 Jun 2015 18:03:09 -0400
+Subject: [PATCH] Make logind, colord, wacom optional and non-automagic
+
+---
+ configure.ac | 31 +++++++++++++++++++++++++++----
+ plugins/Makefile.am | 7 ++++++-
+ 2 files changed, 33 insertions(+), 5 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index ce79a6d..095a7a3 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -260,14 +260,28 @@ dnl ---------------------------------------------------------------------------
+ dnl - color
+ dnl ---------------------------------------------------------------------------
+
+-PKG_CHECK_MODULES(COLOR, [colord >= 0.1.27 cinnamon-desktop >= $CINNAMON_DESKTOP_REQUIRED_VERSION libcanberra-gtk3])
++AC_ARG_ENABLE(color,
++ AS_HELP_STRING([--disable-color], [disable Colord support (default: enabled)]),,
++ enable_color=yes)
++build_color=false
++if test x"$enable_color" != x"no" ; then
++ PKG_CHECK_MODULES(COLOR, [colord >= 0.1.27 cinnamon-desktop >= $CINNAMON_DESKTOP_REQUIRED_VERSION libcanberra-gtk3])
++ build_color=true
++fi
++
++AM_CONDITIONAL(BUILD_COLOR, [test "x$build_color" = "xtrue"])
+
+ dnl ---------------------------------------------------------------------------
+ dnl - wacom
+ dnl ---------------------------------------------------------------------------
++AC_ARG_ENABLE(wacom,
++ AS_HELP_STRING([--disable-wacom], [disable Wacom support (default: auto)]),,
++ enable_wacom=auto)
+ build_wacom=false
+-PKG_CHECK_MODULES(WACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION x11 xi xtst gudev-1.0 cinnamon-desktop xorg-wacom librsvg-2.0 >= $LIBRSVG_REQUIRED_VERSION gtk+-3.0 >= 3.8.0],
+- [build_wacom="true" AC_DEFINE(HAVE_WACOM, 1, [Define if wacom is being build])], [build_wacom="false"])
++if test x"$enable_wacom" != x"no" ; then
++ PKG_CHECK_MODULES(WACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION x11 xi xtst gudev-1.0 cinnamon-desktop xorg-wacom librsvg-2.0 >= $LIBRSVG_REQUIRED_VERSION gtk+-3.0 >= 3.8.0],
++ [build_wacom="true" AC_DEFINE(HAVE_WACOM, 1, [Define if wacom is being build])], [build_wacom="false"])
++fi
+
+ AM_CONDITIONAL(BUILD_WACOM, test "x$build_wacom" = "xtrue")
+
+@@ -373,7 +387,15 @@ dnl ====================================================================
+ dnl Check for logind
+ dnl ====================================================================
+
+-PKG_CHECK_MODULES(LOGIND, [libsystemd-login], [have_logind=yes], [have_logind=no])
++AC_ARG_ENABLE([logind],
++ AS_HELP_STRING([--disable-logind], [Do not check for logind]),
++ [enable_logind=$enableval],
++ [enable_logind=auto])
++
++have_logind=no
++if test x$enable_logind != xno ; then
++ PKG_CHECK_MODULES(LOGIND, [libsystemd-login], [have_logind=yes], [have_logind=no])
++fi
+
+ if test x$have_logind = xyes; then
+ AC_DEFINE(HAVE_LOGIND, 1, [Define if logind is supported])
+@@ -595,6 +617,7 @@ echo "
+ LCMS DICT support: ${have_new_lcms}
+ Libnotify support: ${have_libnotify}
+
++ Colord support: ${build_color}
+ Wacom support: ${build_wacom}
+
+ Smartcard support: ${have_smartcard_support}
+diff --git a/plugins/Makefile.am b/plugins/Makefile.am
+index b9cb3a6..f37eec0 100644
+--- a/plugins/Makefile.am
++++ b/plugins/Makefile.am
+@@ -6,7 +6,6 @@ enabled_plugins = \
+ automount \
+ background \
+ clipboard \
+- color \
+ cursor \
+ dummy \
+ datetime \
+@@ -23,6 +22,12 @@ enabled_plugins = \
+
+ disabled_plugins = $(NULL)
+
++if BUILD_COLOR
++enabled_plugins += color
++else
++disabled_plugins += color
++endif
++
+ if BUILD_WACOM
+ enabled_plugins += wacom
+ else
+--
+2.4.3
+