summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-03-18 23:32:03 -0300
committerPacho Ramos <pacho@gentoo.org>2024-07-16 10:40:30 +0200
commit9a419306d91d507a2fea32fe5980e0342df2f6b0 (patch)
tree0da2e90d7669e77d81463f58237b4b853b756da2 /gnome-extra/gnome-characters
parentgnome-extra/gnome-clocks: update HOMEPAGE (diff)
downloadgentoo-9a419306d91d507a2fea32fe5980e0342df2f6b0.tar.gz
gentoo-9a419306d91d507a2fea32fe5980e0342df2f6b0.tar.bz2
gentoo-9a419306d91d507a2fea32fe5980e0342df2f6b0.zip
gnome-extra/gnome-characters: Bump to 46.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/36843 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-characters')
-rw-r--r--gnome-extra/gnome-characters/Manifest1
-rw-r--r--gnome-extra/gnome-characters/gnome-characters-46.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/gnome-extra/gnome-characters/Manifest b/gnome-extra/gnome-characters/Manifest
index 9238c7db0326..4316fe0e5e44 100644
--- a/gnome-extra/gnome-characters/Manifest
+++ b/gnome-extra/gnome-characters/Manifest
@@ -1 +1,2 @@
DIST gnome-characters-45.0.tar.xz 590000 BLAKE2B 65c05381ae12ea934c09b91d8e58342ca76087703ca5ede0dadfe8c739f4d3152acad1bfa4fc8c5f169fe069fbe12c59f3f70ee242d06ffddfa496535180ef0b SHA512 e7fa6c6caa684ab13c61d6fbf9dee69c0b67f8680dd27b130aaa2248a490e7b234ee541af56fdc6a5d56158636760b25da30a0d479d7f7f5403c35916f93a8ce
+DIST gnome-characters-46.0.tar.xz 592080 BLAKE2B 0c368b2fb59a2fc3e93afb69a2471fd2342640eaa546d4a1e069f94d42bfabb4e6b42668a468010e694a9ca93c164ea8f853347873b43b36dd39d8b12b51f1af SHA512 a68f0c50ffd0beef38423e8a2a2d28ffeee5f001877e77cbb7558dbba53151ceac9545c961f4523ec0e7a7d93cb20da92199b6901b53464f25505c81462eb942
diff --git a/gnome-extra/gnome-characters/gnome-characters-46.0.ebuild b/gnome-extra/gnome-characters/gnome-characters-46.0.ebuild
new file mode 100644
index 000000000000..f811d5090edc
--- /dev/null
+++ b/gnome-extra/gnome-characters/gnome-characters-46.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Unicode character map viewer and library"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/CharacterMap"
+
+LICENSE="GPL-2+ BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/gjs-1.50
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/gobject-introspection-1.35.9:=
+ >=gui-libs/gtk-4.6:4[introspection]
+ >=gui-libs/libadwaita-1.4:1=
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/pango-1.36[introspection]
+ gnome-base/gnome-desktop:4
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/glib
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? ( x11-misc/xvfb-run )
+"
+
+src_test() {
+ meson test -C "${BUILD_DIR}" || die 'tests failed'
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}