summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-05-17 19:21:10 +0200
committerPacho Ramos <pacho@gentoo.org>2019-05-17 19:21:10 +0200
commitd8fffe9fc51361c52bee607c54b5693d77dbfb68 (patch)
tree69aa90cafa2deb9c2245e8668a619de7d8fd2053 /gnome-extra/gnome-shell-extension-applications-overview-tooltip
parentnet-dns/getdns: bump to version 1.5.2 (diff)
downloadgentoo-d8fffe9fc51361c52bee607c54b5693d77dbfb68.tar.gz
gentoo-d8fffe9fc51361c52bee607c54b5693d77dbfb68.tar.bz2
gentoo-d8fffe9fc51361c52bee607c54b5693d77dbfb68.zip
gnome-extra/gnome-shell-extension-applications-overview-tooltip: Bump to v5
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-shell-extension-applications-overview-tooltip')
-rw-r--r--gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-5.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest
index f9ca3a2e56fe..ad459aa13e05 100644
--- a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest
+++ b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest
@@ -1 +1,2 @@
DIST gnome-shell-extension-applications-overview-tooltip-4.tar.gz 79384 BLAKE2B 9e428b66351cb26615050a1c2e8e7ee1e325079b46ae7fc40eb836aef652ca33e04af9b39c07098364b6844c057867e9e5ddee291748afe63084caa108289037 SHA512 befb6f11f7836010077aba10d8664ba462c7153b498e25b5ad0fa12e065dc0b84302b7cc97d1f0685108ea92c20b61491c85a25a4511ad7237b1c0122a587868
+DIST gnome-shell-extension-applications-overview-tooltip-5.tar.gz 79336 BLAKE2B 789e1c91b25ea810ff6575be5c5a83e51800feb9deaf488105593dc36c93c06a16624d4d7704da9de516b1fae053b0108c2e85eef8f0228fc46bc33589328970 SHA512 bde1870b873e8e9aa8d3395414cddf05a3014196e2d860f7ff8fec1dab49f9dbb694420efb89096e498f03a79c76fc7ec3229fab0253dc9b0b31466cfd48d124
diff --git a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-5.ebuild b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-5.ebuild
new file mode 100644
index 000000000000..053787731d20
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Workaround until https://bugzilla.gnome.org/show_bug.cgi?id=663725 is fixed
+DESCRIPTION="Show tooltip with full name and description"
+HOMEPAGE="https://github.com/RaphaelRochet/applications-overview-tooltip"
+SRC_URI="https://github.com/RaphaelRochet/applications-overview-tooltip/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# https://github.com/RaphaelRochet/applications-overview-tooltip/issues/7
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# glib for glib-compile-schemas at build time, needed at runtime anyways
+COMMON_DEPEND="
+ dev-libs/glib:2
+"
+RDEPEND="${COMMON_DEPEND}
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-3.20
+"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/${P/gnome-shell-extension-}"
+
+src_install() {
+ einstalldocs
+ rm -f README.md || die
+ insinto /usr/share/gnome-shell/extensions/applications-overview-tooltip@RaphaelRochet
+ doins -r *
+ glib-compile-schemas "${ED}"/usr/share/gnome-shell/extensions/applications-overview-tooltip@RaphaelRochet/schemas || die
+}
+
+pkg_postinst() {
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}