summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-08-28 12:26:50 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-08-28 12:28:54 -0500
commit59a97bcaa50f1f967873aa5814fcfb9f4bec855e (patch)
treeea29cc9db2aef38ac61009af7dcf02295f17130e /gui-libs/wlroots/wlroots-9999.ebuild
parentdev-ros/image_cb_detector: fix build with boost 1.70 (diff)
downloadgentoo-59a97bcaa50f1f967873aa5814fcfb9f4bec855e.tar.gz
gentoo-59a97bcaa50f1f967873aa5814fcfb9f4bec855e.tar.bz2
gentoo-59a97bcaa50f1f967873aa5814fcfb9f4bec855e.zip
gui-libs/wlroots: 0.7.0 bump
Package-Manager: Portage-2.3.69, Repoman-2.3.17 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-libs/wlroots/wlroots-9999.ebuild')
-rw-r--r--gui-libs/wlroots/wlroots-9999.ebuild28
1 files changed, 1 insertions, 27 deletions
diff --git a/gui-libs/wlroots/wlroots-9999.ebuild b/gui-libs/wlroots/wlroots-9999.ebuild
index db03b0f1e012..540520bfd71d 100644
--- a/gui-libs/wlroots/wlroots-9999.ebuild
+++ b/gui-libs/wlroots/wlroots-9999.ebuild
@@ -18,7 +18,7 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="elogind icccm rootston systemd x11-backend X"
+IUSE="elogind icccm systemd x11-backend X"
REQUIRED_USE="?? ( elogind systemd )"
DEPEND="
@@ -47,8 +47,6 @@ BDEPEND="
virtual/pkgconfig
"
-FILECAPS=( cap_sys_admin usr/bin/rootston )
-
src_configure() {
# xcb-util-errors is not on Gentoo Repository (and upstream seems inactive?)
local emesonargs=(
@@ -57,7 +55,6 @@ src_configure() {
-Dxcb-icccm=$(usex icccm enabled disabled)
-Dxwayland=$(usex X enabled disabled)
-Dx11-backend=$(usex x11-backend enabled disabled)
- $(meson_use rootston)
"-Dexamples=false"
"-Dwerror=false"
)
@@ -72,30 +69,7 @@ src_configure() {
meson_src_configure
}
-src_install() {
- if use rootston; then
- dobin "${BUILD_DIR}"/rootston/rootston
- newdoc rootston/rootston.ini.example rootston.ini
- fi
-
- meson_src_install
-}
-
pkg_postinst() {
elog "You must be in the input group to allow your compositor"
elog "to access input devices via libinput."
- if use rootston; then
- elog ""
- elog "You should copy (and decompress) the example configuration file"
- elog "from ${EROOT:-${ROOT}}/usr/share/doc/${PF}/rootston.ini"
- elog "to the working directory from where you launch rootston"
- elog "(or pass the '-C path-to-config' option to rootston)."
- if ! use systemd && ! use elogind; then
- elog ""
- elog "If you use ConsoleKit2, remember to launch rootston using:"
- elog "exec ck-launch-session rootston"
-
- fcaps_pkg_postinst
- fi
- fi
}