summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-12-11 16:37:54 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-12-11 16:41:55 -0500
commit3625520415e75538e08473aa808bc2437f357eac (patch)
tree51662184640b1cfaf2df10b890abde8ef183d059 /gui-libs
parentapp-emulation/wine-proton: add 9.0.4 (diff)
downloadgentoo-3625520415e75538e08473aa808bc2437f357eac.tar.gz
gentoo-3625520415e75538e08473aa808bc2437f357eac.tar.bz2
gentoo-3625520415e75538e08473aa808bc2437f357eac.zip
gui-libs/egl-x11: add 1.0.0
Identical to 1.0.0_pre20241120 (same commit), except that it's officially tagged now so may as well use it and it's a quick rebuild. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/egl-x11/Manifest1
-rw-r--r--gui-libs/egl-x11/egl-x11-1.0.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/gui-libs/egl-x11/Manifest b/gui-libs/egl-x11/Manifest
index 7359897c30cb..abd863d1d865 100644
--- a/gui-libs/egl-x11/Manifest
+++ b/gui-libs/egl-x11/Manifest
@@ -1,3 +1,4 @@
+DIST egl-x11-1.0.0.tar.gz 71522 BLAKE2B 37fa6459ab3480e58e0b410adccb96c936a47d2d381006e5ca57fa04641b91fa72d66e490692c618bf40e95c8440aaf2f18e0ce3820979d9aeae7e21e0694aac SHA512 b240698bfc6dae02c391e8ff5b5619992a237984a456a433ed0989fd0a805511c88737b87d6d748feb0482fdb5d81c76e9419414d4d1b109097a30412665aafe
DIST egl-x11-1.0.0_pre20240919.tar.gz 71007 BLAKE2B 10793ee854f1548630772579a745c6d12c6add7abea506663b3c196726544353a06eb45a17a42f4fe1c13cb4602750f43d267c8c2be541c31fa34e9aa0f4c7a4 SHA512 b902e39107ec1e6fcd5d10a2741bcb1d3930b947d36c4778d5c3c12d14086d92ad64742f5a5ff2bdfd36c1cc37ac634277221272cb8f5092ff165fcc2c2ecdff
DIST egl-x11-1.0.0_pre20241113.tar.gz 71112 BLAKE2B 991f9825feed3c873264047d324ba76893fa200c5c65705ed1ffda17e72feb50e397edee84ff77faac5e6d50272698557faeaee11f7e3eb8c7a111b27a53471e SHA512 624cb009ce2b920bab2b59b2ac27171e8988862d897125fa9dedfeb62ad075190eb94252f964828f094de069a1196314dcc89e6dd8222ed65f9fb95b32fb26be
DIST egl-x11-1.0.0_pre20241120.tar.gz 71603 BLAKE2B 822ca4b9fa377118dd736aa491670ba47fc0bc9456745f796baa8dab8c41d3e4ad2409853917740942e3d231d541bd3f482402668a51a031c9a7a12f7b4b7b6f SHA512 4b8021779e4cc70104b026021844eed895f8f4ef51708c59c2d53ff5b3789db24c858bbae36c7070833e4c373bc2e974b11ff5924149abc1a1d2091a7397ce09
diff --git a/gui-libs/egl-x11/egl-x11-1.0.0.ebuild b/gui-libs/egl-x11/egl-x11-1.0.0.ebuild
new file mode 100644
index 000000000000..be0bb4b621c1
--- /dev/null
+++ b/gui-libs/egl-x11/egl-x11-1.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson-multilib
+
+DESCRIPTION="NVIDIA X11/XCB EGL external platform library"
+HOMEPAGE="https://github.com/NVIDIA/egl-x11/"
+SRC_URI="
+ https://github.com/NVIDIA/egl-x11/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+# wrt blocker, may or may not cause problems if present with <560
+# drivers, and collides with <565.57.01-r2
+RDEPEND="
+ media-libs/mesa[gbm(+),${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libdrm[${MULTILIB_USEDEP}]
+ x11-libs/libxcb:=[${MULTILIB_USEDEP}]
+ !<x11-drivers/nvidia-drivers-565.57.01-r2
+"
+DEPEND="
+ ${RDEPEND}
+ >=gui-libs/eglexternalplatform-1.2
+ media-libs/libglvnd
+ x11-base/xorg-proto
+"