summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@proton.me>2023-09-27 00:58:21 -0600
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-28 20:51:48 +0300
commit5a227cd7c75467efbbeb481dc409ea50b6765f2d (patch)
tree213c8f6f35c816f260508396256158f6dff10170 /gui-libs
parentgui-libs/wlroots: use the upstream provided tarball (diff)
downloadgentoo-5a227cd7c75467efbbeb481dc409ea50b6765f2d.tar.gz
gentoo-5a227cd7c75467efbbeb481dc409ea50b6765f2d.tar.bz2
gentoo-5a227cd7c75467efbbeb481dc409ea50b6765f2d.zip
gui-libs/wlroots: add xcb-errors USE-flag (0.16.2-r2)
Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/wlroots/wlroots-0.16.2-r2.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/gui-libs/wlroots/wlroots-0.16.2-r2.ebuild b/gui-libs/wlroots/wlroots-0.16.2-r2.ebuild
index 86907c012c03..03002a5a59c8 100644
--- a/gui-libs/wlroots/wlroots-0.16.2-r2.ebuild
+++ b/gui-libs/wlroots/wlroots-0.16.2-r2.ebuild
@@ -19,7 +19,10 @@ else
fi
LICENSE="MIT"
-IUSE="+drm +libinput tinywl vulkan x11-backend X"
+IUSE="+drm +libinput tinywl vulkan x11-backend xcb-errors X"
+REQUIRED_USE="
+ xcb-errors? ( || ( x11-backend X ) )
+"
DEPEND="
>=dev-libs/wayland-1.21.0
@@ -46,6 +49,7 @@ DEPEND="
x11-libs/libxcb:0=
x11-libs/xcb-util-wm
)
+ xcb-errors? ( x11-libs/xcb-util-errors )
"
RDEPEND="
${DEPEND}
@@ -65,9 +69,8 @@ src_configure() {
)
# Separate values with a comma with this evil floating point bit hack
local meson_backends=$(IFS=','; echo "${backends[*]}")
- # xcb-util-errors is not on Gentoo Repository (and upstream seems inactive?)
local emesonargs=(
- "-Dxcb-errors=disabled"
+ $(meson_feature xcb-errors)
$(meson_use tinywl examples)
-Drenderers=$(usex vulkan 'gles2,vulkan' gles2)
$(meson_feature X xwayland)