summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-07-23 10:04:40 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-07-23 11:04:52 -0400
commit7c50331279b24b3f89cd6d161d1b088d30961062 (patch)
tree4a4518f6eb609e491987dc1c04d0fad4d45a40f1 /gui-libs
parentdev-libs/openssl: Keyword 3.3.1 for ~m68k (diff)
downloadgentoo-7c50331279b24b3f89cd6d161d1b088d30961062.tar.gz
gentoo-7c50331279b24b3f89cd6d161d1b088d30961062.tar.bz2
gentoo-7c50331279b24b3f89cd6d161d1b088d30961062.zip
gui-libs/eglexternalplatform: move .pc file to /usr/share
get_libdir never made sense here, this is only headers and is now causing trouble for revdeps wanting multilib Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/eglexternalplatform/eglexternalplatform-1.1-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/gui-libs/eglexternalplatform/eglexternalplatform-1.1-r1.ebuild b/gui-libs/eglexternalplatform/eglexternalplatform-1.1-r1.ebuild
new file mode 100644
index 000000000000..a040aff76b2f
--- /dev/null
+++ b/gui-libs/eglexternalplatform/eglexternalplatform-1.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="EGL External Platform interface"
+HOMEPAGE="https://github.com/NVIDIA/eglexternalplatform"
+SRC_URI="
+ https://github.com/NVIDIA/eglexternalplatform/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+src_prepare() {
+ default
+
+ use !prefix || sed -i "/^inc/s|=|=${EPREFIX}|" eglexternalplatform.pc || die
+}
+
+src_install() {
+ insinto /usr/share/pkgconfig
+ doins eglexternalplatform.pc
+
+ insinto /usr/include/EGL
+ doins interface/*.h
+
+ einstalldocs
+
+ docinto examples
+ dodoc samples/*.c
+}