summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-05-12 09:42:48 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-12 10:12:39 +0200
commit8ad7c2e0f13807f5037ffa4c7fa18a5ee5127dfd (patch)
tree4b43e579b2db1a0976f48d4c40a3108996c5aeef /kde-apps/dolphin
parentapp-admin/selint: amd64 stable wrt bug #789438 (diff)
downloadgentoo-8ad7c2e0f13807f5037ffa4c7fa18a5ee5127dfd.tar.gz
gentoo-8ad7c2e0f13807f5037ffa4c7fa18a5ee5127dfd.tar.bz2
gentoo-8ad7c2e0f13807f5037ffa4c7fa18a5ee5127dfd.zip
kde-apps/dolphin: Update fix-no-semantic-desktop.patch w/ upstream MR
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/dolphin')
-rw-r--r--kde-apps/dolphin/dolphin-20.12.3-r1.ebuild4
-rw-r--r--kde-apps/dolphin/dolphin-21.04.0.ebuild4
-rw-r--r--kde-apps/dolphin/files/dolphin-21.04.0-fix-no-semantic-desktop.patch23
-rw-r--r--kde-apps/dolphin/files/dolphin-21.04.1-fix-no-semantic-desktop.patch41
4 files changed, 45 insertions, 27 deletions
diff --git a/kde-apps/dolphin/dolphin-20.12.3-r1.ebuild b/kde-apps/dolphin/dolphin-20.12.3-r1.ebuild
index 84ed6041e315..76be41e62f66 100644
--- a/kde-apps/dolphin/dolphin-20.12.3-r1.ebuild
+++ b/kde-apps/dolphin/dolphin-20.12.3-r1.ebuild
@@ -64,8 +64,8 @@ RDEPEND="${DEPEND}
PATCHES=(
"${FILESDIR}/${P}-fix-session-restore-w-o-tabs.patch" # KDE-bug 434911
- # TODO: Downstream hack, track upstream bug for better solution
- "${FILESDIR}/${PN}-21.04.0-fix-no-semantic-desktop.patch" # KDE-bug 435586
+ # pending https://invent.kde.org/system/dolphin/-/merge_requests/208
+ "${FILESDIR}/${PN}-21.04.1-fix-no-semantic-desktop.patch" # KDE-bug 435586
)
src_configure() {
diff --git a/kde-apps/dolphin/dolphin-21.04.0.ebuild b/kde-apps/dolphin/dolphin-21.04.0.ebuild
index c9439d4dddc3..6c4eb30ae3d1 100644
--- a/kde-apps/dolphin/dolphin-21.04.0.ebuild
+++ b/kde-apps/dolphin/dolphin-21.04.0.ebuild
@@ -62,8 +62,8 @@ RDEPEND="${DEPEND}
>=kde-apps/kio-extras-${PVCUT}:5
"
-# TODO: Downstream hack, track upstream bug for better solution
-PATCHES=( "${FILESDIR}/${P}-fix-no-semantic-desktop.patch" ) # KDE-bug 435586
+# pending https://invent.kde.org/system/dolphin/-/merge_requests/208
+PATCHES=( "${FILESDIR}/${PN}-21.04.1-fix-no-semantic-desktop.patch" ) # KDE-bug 435586
src_configure() {
local mycmakeargs=(
diff --git a/kde-apps/dolphin/files/dolphin-21.04.0-fix-no-semantic-desktop.patch b/kde-apps/dolphin/files/dolphin-21.04.0-fix-no-semantic-desktop.patch
deleted file mode 100644
index 4f97a53c5230..000000000000
--- a/kde-apps/dolphin/files/dolphin-21.04.0-fix-no-semantic-desktop.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-diff --git a/src/search/dolphinfacetswidget.cpp b/src/search/dolphinfacetswidget.cpp
-index d52d146a8..9f0078631 100644
---- a/src/search/dolphinfacetswidget.cpp
-+++ b/src/search/dolphinfacetswidget.cpp
-@@ -7,6 +7,8 @@
-
- #include "dolphinfacetswidget.h"
-
-+#include <config-baloo.h>
-+
- #include <KLocalizedString>
-
- #include <QComboBox>
-@@ -257,7 +259,9 @@ void DolphinFacetsWidget::updateTagsSelector()
- void DolphinFacetsWidget::updateTagsMenu()
- {
- updateTagsMenuItems({}, {});
-+#ifdef HAVE_BALOO
- m_tagsLister.openUrl(QUrl(QStringLiteral("tags:/")), KCoreDirLister::OpenUrlFlag::Reload);
-+#endif
- }
-
- void DolphinFacetsWidget::updateTagsMenuItems(const QUrl&, const KFileItemList& items)
diff --git a/kde-apps/dolphin/files/dolphin-21.04.1-fix-no-semantic-desktop.patch b/kde-apps/dolphin/files/dolphin-21.04.1-fix-no-semantic-desktop.patch
new file mode 100644
index 000000000000..5636d0532ed4
--- /dev/null
+++ b/kde-apps/dolphin/files/dolphin-21.04.1-fix-no-semantic-desktop.patch
@@ -0,0 +1,41 @@
+From 29636baff0f0cf8d769aa75b1c458b96cf83b828 Mon Sep 17 00:00:00 2001
+From: Ismael Asensio <isma.af@gmail.com>
+Date: Sun, 9 May 2021 21:10:44 +0200
+Subject: [PATCH] search/facetswidget: Check for protocol before trying to
+ fetch tags
+
+This was causing an error when trying to list items from the
+non-existent `tags:` protocol.
+
+BUG: 435586
+FIXED-IN: 21.04.1
+---
+ src/search/dolphinfacetswidget.cpp | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/src/search/dolphinfacetswidget.cpp b/src/search/dolphinfacetswidget.cpp
+index d4079f1eb..e8a43101f 100644
+--- a/src/search/dolphinfacetswidget.cpp
++++ b/src/search/dolphinfacetswidget.cpp
+@@ -8,6 +8,7 @@
+ #include "dolphinfacetswidget.h"
+
+ #include <KLocalizedString>
++#include <KProtocolInfo>
+
+ #include <QComboBox>
+ #include <QDate>
+@@ -245,7 +246,9 @@ void DolphinFacetsWidget::updateTagsSelector()
+ void DolphinFacetsWidget::updateTagsMenu()
+ {
+ updateTagsMenuItems({}, {});
+- m_tagsLister.openUrl(QUrl(QStringLiteral("tags:/")), KCoreDirLister::OpenUrlFlag::Reload);
++ if (KProtocolInfo::isKnownProtocol(QStringLiteral("tags"))) {
++ m_tagsLister.openUrl(QUrl(QStringLiteral("tags:/")), KCoreDirLister::OpenUrlFlag::Reload);
++ }
+ }
+
+ void DolphinFacetsWidget::updateTagsMenuItems(const QUrl&, const KFileItemList& items)
+--
+GitLab
+