summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-06 16:04:23 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-06 17:06:07 +0200
commit8ea97068f86f7c38eb7eba7b4834d24395ea63c8 (patch)
tree1a99302b57a044d70ab6ffc235920f12cd030996 /kde-apps/libkgeomap/libkgeomap-19.04.2.ebuild
parentdev-texlive/texlive-luatex: Add more blockers (diff)
downloadgentoo-8ea97068f86f7c38eb7eba7b4834d24395ea63c8.tar.gz
gentoo-8ea97068f86f7c38eb7eba7b4834d24395ea63c8.tar.bz2
gentoo-8ea97068f86f7c38eb7eba7b4834d24395ea63c8.zip
kde-apps: Add KDE Applications 19.04.2
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'kde-apps/libkgeomap/libkgeomap-19.04.2.ebuild')
-rw-r--r--kde-apps/libkgeomap/libkgeomap-19.04.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/kde-apps/libkgeomap/libkgeomap-19.04.2.ebuild b/kde-apps/libkgeomap/libkgeomap-19.04.2.ebuild
new file mode 100644
index 000000000000..cb77c098f1b0
--- /dev/null
+++ b/kde-apps/libkgeomap/libkgeomap-19.04.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Wrapper library for world map components as marble, openstreetmap and googlemap"
+HOMEPAGE="https://www.digikam.org/"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_kdeapps_dep marble 'kde' '' '5=')
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtgui)
+ >=dev-qt/qtwebkit-5.212.0_pre20180120:5
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ use test && local mycmakeargs=( -DCMAKE_DISABLE_FIND_PACKAGE_KF5KExiv2=true )
+
+ kde5_src_configure
+}