summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-12 18:25:02 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-12 18:28:13 +0100
commit0a04dbe4bdce4ba9c45b21310d7a26c95b2530ac (patch)
tree0e4a9ab3a24db08d0f6c7b61b0d5821e99bd4497 /kde-apps/mailcommon
parentecm.eclass: cmake-utils_use_find_package -> cmake_use_find_package (diff)
downloadgentoo-0a04dbe4bdce4ba9c45b21310d7a26c95b2530ac.tar.gz
gentoo-0a04dbe4bdce4ba9c45b21310d7a26c95b2530ac.tar.bz2
gentoo-0a04dbe4bdce4ba9c45b21310d7a26c95b2530ac.zip
kde-apps: Add KDE Release Service 19.12.0
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/mailcommon')
-rw-r--r--kde-apps/mailcommon/Manifest1
-rw-r--r--kde-apps/mailcommon/mailcommon-19.12.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/kde-apps/mailcommon/Manifest b/kde-apps/mailcommon/Manifest
index 9556af24a55f..eff03c0dcef5 100644
--- a/kde-apps/mailcommon/Manifest
+++ b/kde-apps/mailcommon/Manifest
@@ -1 +1,2 @@
DIST mailcommon-19.08.3.tar.xz 693672 BLAKE2B 2be6b716903e83a8e9397a24d8f062b65180e39fef1b0d784804a9bb09a1760d66a2099c331da6456c3bac7654d91c238acc3275961fbd4234afdc11c8784470 SHA512 d1bf8aea689f0cb24dc2030c258795465b3a5e5c16bb49a2f35f62b999faf97cb40f0dd3d4e2bd2d6033e48438bc693fddcfa69d34ad799f4fb22d808f9b06ff
+DIST mailcommon-19.12.0.tar.xz 701872 BLAKE2B 72f2a8b0df0da87fd7d711b5471b1d4a9b901b71900d70fdd1bd5c58ee2fc4afc6d01c9aa199af9617499de7a13cd860d8f7218308e33da4d6ec891385785e81 SHA512 6fda0b5c7afcb5b66dbb5730ce2256bae2ca0e775a6b32fec9ecb1dde8f38962b16786b71ec7b31c40d0e9f482f47507fdd59c8b0b0bf31b4fda016a54e4107f
diff --git a/kde-apps/mailcommon/mailcommon-19.12.0.ebuild b/kde-apps/mailcommon/mailcommon-19.12.0.ebuild
new file mode 100644
index 000000000000..bac06c66994a
--- /dev/null
+++ b/kde-apps/mailcommon/mailcommon-19.12.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_DESIGNERPLUGIN="true"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.63.0
+QTMIN=5.12.3
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Common mail library"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+# drop qtwidgets subslot operator when QT_MINIMAL >= 5.14.0
+BDEPEND="
+ dev-libs/libxslt
+"
+DEPEND="
+ >=kde-frameworks/karchive-${KFMIN}:5
+ >=kde-frameworks/kcodecs-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcontacts-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kitemmodels-${KFMIN}:5
+ >=kde-frameworks/kitemviews-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/syntax-highlighting-${KFMIN}:5
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-contacts-${PVCUT}:5
+ >=kde-apps/akonadi-mime-${PVCUT}:5
+ >=kde-apps/kmailtransport-${PVCUT}:5
+ >=kde-apps/kmime-${PVCUT}:5
+ >=kde-apps/kpimtextedit-${PVCUT}:5
+ >=kde-apps/libkdepim-${PVCUT}:5
+ >=kde-apps/mailimporter-${PVCUT}:5
+ >=kde-apps/messagelib-${PVCUT}:5
+ >=kde-apps/pimcommon-${PVCUT}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtmultimedia-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5=
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=media-libs/phonon-4.10.90
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-l10n
+"
+
+RESTRICT+=" test"