summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-08-12 11:49:02 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-08-12 12:19:05 +0200
commitdb1f974cfaa8aab11948987533aed79067d39c79 (patch)
treeb9ce8b7a8210b95774d8ba82a3f421e2c3f0fd0b /kde-apps/print-manager
parentkde-apps/kwalletmanager: 21.08.0 version bump (diff)
downloadgentoo-db1f974cfaa8aab11948987533aed79067d39c79.tar.gz
gentoo-db1f974cfaa8aab11948987533aed79067d39c79.tar.bz2
gentoo-db1f974cfaa8aab11948987533aed79067d39c79.zip
kde-apps/print-manager: 21.08.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/print-manager')
-rw-r--r--kde-apps/print-manager/Manifest1
-rw-r--r--kde-apps/print-manager/print-manager-21.08.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/kde-apps/print-manager/Manifest b/kde-apps/print-manager/Manifest
index 24622f20b010..ed9f2a6e1918 100644
--- a/kde-apps/print-manager/Manifest
+++ b/kde-apps/print-manager/Manifest
@@ -1 +1,2 @@
DIST print-manager-21.04.3.tar.xz 263964 BLAKE2B 9e2646b618bd4b64d811ae920880414ca11b78dcdd74a815194499929d453649bc08d0a9b3043d472cedeef10ff66acdd64f63e499c6d68ced24cfda4abcc898 SHA512 6ee679f46301213dcccc15212f78c23aff173d9fab2f26a492cc7e07e95c5f1fa98a2feea5a42d3f0460ac3b7ce8147f5624cdc36c4def74f15dd2b924f9412b
+DIST print-manager-21.08.0.tar.xz 270244 BLAKE2B 1b5b89f0700f7c6489ea64666b8f1713e14c9a78047ead37df7c67a8ef5b2de8b4aae5a952f29dff79c84e357a9d3765dfc6c696ba4fdfca4fe8934dfea78704 SHA512 140047743ae2b019b424e569ea23a4f85a225875114a555343963e200085dd7f6dca951405f19eda27cb6ebdd6068cce3009af0b843d2698a7c5405b53bbff20
diff --git a/kde-apps/print-manager/print-manager-21.08.0.ebuild b/kde-apps/print-manager/print-manager-21.08.0.ebuild
new file mode 100644
index 000000000000..dcc2589a34e3
--- /dev/null
+++ b/kde-apps/print-manager/print-manager-21.08.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.84.0
+PLASMA_MINIMAL=5.16.5
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Manage print jobs and printers in Plasma"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="+gtk"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/plasma-${KFMIN}:5
+ net-print/cups
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-plasma/kde-cli-tools-${PLASMA_MINIMAL}:5
+ gtk? ( app-admin/system-config-printer )
+"
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]] && ! use gtk ; then
+ ewarn "By switching off \"gtk\" USE flag, you have chosen to do without"
+ ewarn "an important, though optional, runtime dependency:"
+ ewarn
+ ewarn "app-admin/system-config-printer"
+ ewarn
+ ewarn "${PN} will work nevertheless, but is going to be less comfortable"
+ ewarn "and will show the following error status during runtime:"
+ ewarn
+ ewarn "\"Failed to group devices: 'The name org.fedoraproject.Config.Printing"
+ ewarn "was not provided by any .service files'\""
+ fi
+}