summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-10-10 21:19:48 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-12 23:13:14 +0200
commita7030fcd38880ac327f749bb528f65a0a4ee7ae7 (patch)
tree08ecff369172b6779cc7b6295ff2f1a069b73859 /kde-frameworks/kauth
parentapp-office/kraft: Accept kde-frameworks/kcontacts (diff)
downloadgentoo-a7030fcd38880ac327f749bb528f65a0a4ee7ae7.tar.gz
gentoo-a7030fcd38880ac327f749bb528f65a0a4ee7ae7.tar.bz2
gentoo-a7030fcd38880ac327f749bb528f65a0a4ee7ae7.zip
kde-frameworks: Add KDE Frameworks 5.63.0
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kauth')
-rw-r--r--kde-frameworks/kauth/Manifest1
-rw-r--r--kde-frameworks/kauth/kauth-5.63.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-frameworks/kauth/Manifest b/kde-frameworks/kauth/Manifest
index 2ce3081826bf..39d3f484dc1f 100644
--- a/kde-frameworks/kauth/Manifest
+++ b/kde-frameworks/kauth/Manifest
@@ -1,2 +1,3 @@
DIST kauth-5.60.0.tar.xz 85272 BLAKE2B 83c6e9901deb24413e0a3fe81812afb501a4c1517d550234a3945cdc520ba2ee5da4024571c9a25908090c5e8f083102c9ed554d94b81f86132f3c9c688ee146 SHA512 f35c904f22d04af26cca20fdc4c565203ef929e8efb7678aed8aa97d14d8be35e06a03e7db64a2bc4c17f9983072208fa4350c85790cca784bc4f1d81b2a7fd9
DIST kauth-5.62.0.tar.xz 86180 BLAKE2B 522bc4bda38e1e2c069d5f8e659bea56a8427b2e1325a508176d6485539615c400698964e427d9abeb24cf3c72ee090fd3d17dab8657a5073ee1f252e8876ca3 SHA512 c7ddb3c8a0e48ce51285e9fa0327d735971f0873201d4b2d5c59bb3b22d93f2dc3cb30398c342abbe88b87fb2c5395afc45b44385d9e0bc8ea3a1f673f5569f5
+DIST kauth-5.63.0.tar.xz 85876 BLAKE2B cf5a0bbb982d1085f8f9c0d47648ea1f81b7cc824b9fc7acd1a980d5e60518b5347b2063d006ed2a13f5cb2e9c4ca718c0b0c42a76e2ab6f31a6ccbeae1f2b28 SHA512 f4ef0874368b6c1543a9ee4b41039fe0a291d40c0535f5d1c1c1258dc842ea389c266bcd720d7039d6bccac52c1f305602b488c7018b1f9c7084f5fec63bfe73
diff --git a/kde-frameworks/kauth/kauth-5.63.0.ebuild b/kde-frameworks/kauth/kauth-5.63.0.ebuild
new file mode 100644
index 000000000000..396d6cb72e1a
--- /dev/null
+++ b/kde-frameworks/kauth/kauth-5.63.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework to let applications perform actions as a privileged user"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls +policykit"
+
+BDEPEND="
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ policykit? ( sys-auth/polkit-qt[qt5(+)] )
+"
+RDEPEND="${DEPEND}"
+PDEPEND="policykit? ( kde-plasma/polkit-kde-agent )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package policykit PolkitQt5-1)
+ )
+
+ kde5_src_configure
+}
+
+src_test() {
+ # KAuthHelperTest test fails, bug 654842
+ local myctestargs=(
+ -E "(KAuthHelperTest)"
+ )
+
+ kde5_src_test
+}