summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-01-08 12:07:18 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-01-08 22:07:48 +0100
commit61e28b0a121354c4d6d39289c3116d76cc8008f7 (patch)
tree232658f22a70f5c0cc693a861f72e096b79efe7c /kde-frameworks/kcompletion
parentkde-frameworks/kauth: 5.90.0 version bump (diff)
downloadgentoo-61e28b0a121354c4d6d39289c3116d76cc8008f7.tar.gz
gentoo-61e28b0a121354c4d6d39289c3116d76cc8008f7.tar.bz2
gentoo-61e28b0a121354c4d6d39289c3116d76cc8008f7.zip
kde-frameworks/kcompletion: 5.90.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kcompletion')
-rw-r--r--kde-frameworks/kcompletion/Manifest1
-rw-r--r--kde-frameworks/kcompletion/kcompletion-5.90.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/kde-frameworks/kcompletion/Manifest b/kde-frameworks/kcompletion/Manifest
index 49246cc260b7..6629acc0e49b 100644
--- a/kde-frameworks/kcompletion/Manifest
+++ b/kde-frameworks/kcompletion/Manifest
@@ -1,2 +1,3 @@
DIST kcompletion-5.88.0.tar.xz 122892 BLAKE2B 182fe181fb06e1d8387b31c50a8cfb64b141e146d8982bca4c13b964eed9ed54244e69fc9382470dfbf2a258af333b5e11ef150bb76520dd3218524d14478467 SHA512 4a2c42014b1d6e933a48e289a1c3ed8dc6ad4aee95eb8f2195c52272dcd57a7b1e4b97bad8ab72ce3800591accf2a2cb561997b828275ecf8f8f34727368bd6b
DIST kcompletion-5.89.0.tar.xz 125000 BLAKE2B db34368b055654ffe6929ec9966fda3bf8221c27aac54ce95606214094a1ffc75881e17d9561e64f8d11fb8ea312380510c4928c74d6223650e2b9dc7a9bf840 SHA512 309da1384416531d6a88b2988bb41e098de29ebfc2d23c7a00fe706b4345be2d5275c7f1a561ee284d8dcb28cd09b0ecf5d83a4d3a7f02809ddd68b7bd3ee150
+DIST kcompletion-5.90.0.tar.xz 125136 BLAKE2B 37aea1f883f1af1585ad0d2b25ef148acae2c99996e2e633148df36c0f08c7d1351f082359d1352c3e8fe4aa9b2c10daf62f8a6909a5207c528d3f236ad6e08c SHA512 c3a793fe565641d282326f82f9261f8a181f83afbf52ea5c82d418af343766ae012f4df5fda7f578438b41029846aa507fa6358140113073ca796f4c012ff6de
diff --git a/kde-frameworks/kcompletion/kcompletion-5.90.0.ebuild b/kde-frameworks/kcompletion/kcompletion-5.90.0.ebuild
new file mode 100644
index 000000000000..38f8abad8cc2
--- /dev/null
+++ b/kde-frameworks/kcompletion/kcompletion-5.90.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_DESIGNERPLUGIN="true"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for common completion tasks such as filename or URL completion"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="nls"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_PythonModuleGeneration=ON # bug 746866
+ )
+ ecm_src_configure
+}