summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-06-07 20:47:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-06-12 17:28:16 +0200
commit64e5c04771399f924f1b70416a1ff73333191fa5 (patch)
tree911a27e35e0fcf647c62473cbd4b8b089027976c /kde-frameworks/kpeople/kpeople-6.3.0.ebuild
parentkde-frameworks/kparts: 6.3.0 version bump (diff)
downloadgentoo-64e5c04771399f924f1b70416a1ff73333191fa5.tar.gz
gentoo-64e5c04771399f924f1b70416a1ff73333191fa5.tar.bz2
gentoo-64e5c04771399f924f1b70416a1ff73333191fa5.zip
kde-frameworks/kpeople: 6.3.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kpeople/kpeople-6.3.0.ebuild')
-rw-r--r--kde-frameworks/kpeople/kpeople-6.3.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/kde-frameworks/kpeople/kpeople-6.3.0.ebuild b/kde-frameworks/kpeople/kpeople-6.3.0.ebuild
new file mode 100644
index 000000000000..1b5609fd93f3
--- /dev/null
+++ b/kde-frameworks/kpeople/kpeople-6.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=6.6.2
+VIRTUALX_REQUIRED="test" # bug 816588 (test fails)
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="KDE contact person abstraction library"
+HOMEPAGE="https://invent.kde.org/frameworks/kpeople"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,sql,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ =kde-frameworks/kconfig-${PVCUT}*:6
+ =kde-frameworks/kcontacts-${PVCUT}*:6
+ =kde-frameworks/kcoreaddons-${PVCUT}*:6
+ =kde-frameworks/ki18n-${PVCUT}*:6
+ =kde-frameworks/kitemviews-${PVCUT}*:6
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:6
+"
+RDEPEND="${DEPEND}"
+
+src_test() {
+ local CMAKE_SKIP_TESTS=(
+ # bug 668192, segfaults
+ persondatatest
+ )
+
+ ecm_src_test -j1
+}