summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-11-08 15:28:47 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-11-08 15:38:11 +0100
commit52da3e885a8abe5855f97221d14746528045d2a4 (patch)
tree6ac0306728b85525eda2f3f754b69c1bd1e5b53b /kde-frameworks/kpeople
parentkde-frameworks/kparts: 6.8.0 version bump (diff)
downloadgentoo-52da3e885a8abe5855f97221d14746528045d2a4.tar.gz
gentoo-52da3e885a8abe5855f97221d14746528045d2a4.tar.bz2
gentoo-52da3e885a8abe5855f97221d14746528045d2a4.zip
kde-frameworks/kpeople: 6.8.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kpeople')
-rw-r--r--kde-frameworks/kpeople/Manifest1
-rw-r--r--kde-frameworks/kpeople/kpeople-6.8.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-frameworks/kpeople/Manifest b/kde-frameworks/kpeople/Manifest
index 53b3063a7b62..88a2296aca56 100644
--- a/kde-frameworks/kpeople/Manifest
+++ b/kde-frameworks/kpeople/Manifest
@@ -1,2 +1,3 @@
DIST kpeople-6.6.0.tar.xz 66668 BLAKE2B 7c6422d5f383574fda97bf20ee1b8a472f4ed0985e344a2cdad69a25727b71b2d56be400f0c207db81c4b59217049737f830b6795e01792e0a07233cf4ebcd3c SHA512 6aeaf9ee21f4a6c57b8783a49914a6e6be702d20ad700df1ef401990df83554f17c7805a396345dff6f3f66d8e56f796e2f4d9015f0671d1873d2397a6bf8aac
DIST kpeople-6.7.0.tar.xz 66676 BLAKE2B 5ef3f40617d65f0e4381c8360085635c29e59a312eee7fb2c29fa96243e092adc890e7a17b4169756ccabc31dda7a48e0b409a656d616be13844edb8b4da3fe9 SHA512 d46b4151d7924922c66acaffffbb5a6b8c0e0f45c06ba71b0834eb5be260e9d5c43ec93f3d7cb5a8e6ce886a2469479cc904e0762fd435bc43b9d8c5e50ab503
+DIST kpeople-6.8.0.tar.xz 66688 BLAKE2B 22e7f255051bd185e3c824b2a6f0a0744f2d6321721beff37ed02542fc5d315aa07a23976abf69e45a61d68fb07c1c490aa9103df9ac46be4db51f139a5c9a5a SHA512 38cbfc105cb8ff12d528e13cf2fc9e7dba0868b2076cca7d1fe984e457982bfd5f3fc1d2613e16dd92a6df24e76efca0f9ac7ca0897bcdb23fa3ff70611b82cd
diff --git a/kde-frameworks/kpeople/kpeople-6.8.0.ebuild b/kde-frameworks/kpeople/kpeople-6.8.0.ebuild
new file mode 100644
index 000000000000..a749077b3140
--- /dev/null
+++ b/kde-frameworks/kpeople/kpeople-6.8.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=6.7.2
+VIRTUALX_REQUIRED="test" # bug 816588 (test fails)
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="KDE contact person abstraction library"
+HOMEPAGE="https://invent.kde.org/frameworks/kpeople"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,sql,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ =kde-frameworks/kconfig-${PVCUT}*:6
+ =kde-frameworks/kcontacts-${PVCUT}*:6
+ =kde-frameworks/kcoreaddons-${PVCUT}*:6
+ =kde-frameworks/ki18n-${PVCUT}*:6
+ =kde-frameworks/kitemviews-${PVCUT}*:6
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:6
+"
+RDEPEND="${DEPEND}"
+
+src_test() {
+ local CMAKE_SKIP_TESTS=(
+ # bugs 668192, 816588: segfaults w/o virtx
+ personsmodeltest
+ )
+
+ ecm_src_test -j1
+}