summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-09 19:09:42 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-09 19:47:17 +0100
commit2d191df87083c3e17db0ce6e815f93883be4172c (patch)
tree609994abfb68e69f566162d204dc062c4f851434 /kde-frameworks/sonnet
parentmedia-libs/gegl: 0.2 with ffmpeg 4 (diff)
downloadgentoo-2d191df87083c3e17db0ce6e815f93883be4172c.tar.gz
gentoo-2d191df87083c3e17db0ce6e815f93883be4172c.tar.bz2
gentoo-2d191df87083c3e17db0ce6e815f93883be4172c.zip
kde-frameworks: Add KDE Frameworks 5.56.0
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/sonnet')
-rw-r--r--kde-frameworks/sonnet/Manifest1
-rw-r--r--kde-frameworks/sonnet/sonnet-5.56.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/Manifest b/kde-frameworks/sonnet/Manifest
index 477ab73320af..ec819026b264 100644
--- a/kde-frameworks/sonnet/Manifest
+++ b/kde-frameworks/sonnet/Manifest
@@ -1,2 +1,3 @@
DIST sonnet-5.54.0.tar.xz 286720 BLAKE2B 6e603c8381ea5081f72896b12a7bca7d5eae6d8dac311f6120adad90a5c062b2707fa0276b2dd893eb3ce069fb4d0d2de63ad974e2ab8bf8e795a0d8cadc1a7c SHA512 fe7551fb65fe896a872c3f0af4ce1c60f4b974f993465b5ae7b3eea219a0964f7ae5107aa9346884ffd37c95b4bf7ea0bed05592245978c07fd633af88eeca88
DIST sonnet-5.55.0.tar.xz 287456 BLAKE2B 7608dddc5eb3be59980de737a57521e7f56c80c5e5784f36694578fc3f8b39143d99ddbc163288de7f9472e521cfd3af7fad3b513295fa719f3b3f36fdd2697b SHA512 f159bbc605d454d90118a5757c2c005fc3d1a0d13772bb4a571a59cc637a455b270372123bafddafd20587b2710e32c7df22e507745d30c556a72a48a6b6d296
+DIST sonnet-5.56.0.tar.xz 287764 BLAKE2B ca9630732907d658e057b528f873e5501c8c0b5b9f74167a48e0fcabfb22c4fe78fbea9392270de7197ed05ac15e9c264d92b7f7221c506397a759df0933dad7 SHA512 5f00bf013b5fbbf510e25630f770b408ebff12c1b1972f824953eedec542fbc9efa16f749893bc0f1fca67adef88c3bfd74ad3e60592fbf1806a8220947646ca
diff --git a/kde-frameworks/sonnet/sonnet-5.56.0.ebuild b/kde-frameworks/sonnet/sonnet-5.56.0.ebuild
new file mode 100644
index 000000000000..cc912eb777c3
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.56.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="aspell +hunspell nls"
+
+BDEPEND="
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+DEPEND="
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell:= )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package aspell ASPELL)
+ $(cmake-utils_use_find_package hunspell HUNSPELL)
+ )
+
+ kde5_src_configure
+}